Bug 63810 - xssfSheet.class file broken
Summary: xssfSheet.class file broken
Status: RESOLVED WORKSFORME
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-06 15:22 UTC by gundae
Modified: 2019-11-02 13:40 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gundae 2019-10-06 15:22:37 UTC
When importing poi 4.0.1, 4.1.0, it shows that the xssfSheet.class file in the xssf folder cannot be found.
Other files are fine, but only xssfSheet.class file can't be read.

When I use the decompiler, only this class file is broken. Can I tell what the statement is?
Comment 1 Dominik Stadler 2019-10-06 16:20:37 UTC
Many people are using POI successfully when using that class-file, so this is likely related to your local environment.

Can you describe in as much detail as possible how this can be reproduced? Please also try it on another machine or in a clean new project so you verify that it is not caused by something in your environment, e.g. having a stale .class-file somewhere in your environment may cause this.

Unless we get a clear and reproducible way to cause the problem I fear there is not much we can do as it works for everybody else on many different setups...
Comment 2 gundae 2019-10-07 02:22:02 UTC
This problem cannot be related to the environment
This is a decompileable program. It only crashes when you open the xssfSheer.class file.

All other classes do not have this problem.

This problem occurs when I unzip after downloading.
The same problem occurs when you import the jar.

Could you please reimport only xssfSheet.class file?
Comment 3 Dominik Stadler 2019-11-02 13:40:29 UTC
We have multiple CI jobs which recompile Apache POI in various ways as well as a number of downstream applications and utilities which all make use of XSSF functionality and thus are also using class XSSFSheet, none of them shows any such problem, so unless you can show us how exactly you reproduce a problem for you I fear we are not able to do much here.