Bug 64027 - This is regarding the below method - IOUtils.setByteArrayMaxOverride
Summary: This is regarding the below method - IOUtils.setByteArrayMaxOverride
Status: RESOLVED DUPLICATE of bug 64001
Alias: None
Product: POI
Classification: Unclassified
Component: POI Overall (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-12-23 07:04 UTC by Sushmita Nag
Modified: 2019-12-24 09:31 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sushmita Nag 2019-12-23 07:04:42 UTC
hi Team,

We are using POI-4.0.1 for manipulating advanced properties of MS office files. And in order to do that, we have encountered the below exception while working with one of the file. So, as per the message below, its suggested to set higher override value with IOUtils.setByteArrayMaxOverride(). Hence, i would like to know what value to provide as a parameter to setByteArrayMaxOverride() method. Could you please suggest ?



Caused by: org.apache.poi.util.RecordFormatException: Tried to allocate an array of length 140628, but 100000 is the maximum for this record type.
If the file is not corrupt, please open an issue on bugzilla to request 
increasing the maximum allowable size for this record type.
As a temporary workaround, consider setting a higher override value with IOUtils.setByteArrayMaxOverride()


Regards,
Sushmita
Comment 1 PJ Fanning 2019-12-23 09:05:04 UTC
There are problems with the max override code - see https://bz.apache.org/bugzilla/show_bug.cgi?id=64001
Comment 2 Sushmita Nag 2019-12-24 07:05:09 UTC
hi,

So, is there any solution for the above issue ? As our Customer is totally blocked because of the above issue where in they are not able to upload a certain document of 2.5 MB because of org.apache.poi.util.RecordFormatException.

Could you please let us know how do we proceed from here ?

Regards,
Sushmita
Comment 3 PJ Fanning 2019-12-24 09:31:00 UTC
I added a comment on https://bz.apache.org/bugzilla/show_bug.cgi?id=64001 - closing this so that we don't have duplicate issues floating around

*** This bug has been marked as a duplicate of bug 64001 ***