Bug 64142 - Presence of DebugPostProcessor in Test plan breaks ActiveThread Over time in report due to missing information
Summary: Presence of DebugPostProcessor in Test plan breaks ActiveThread Over time in ...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 3.0
Hardware: All All
: P2 major (vote)
Target Milestone: JMETER_5.3.0
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
: 64176 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-14 07:22 UTC by Philippe Mouawad
Modified: 2020-03-07 18:13 UTC (History)
2 users (show)



Attachments
ActiveThreadsOverTime showing we have a plateau at 1159 Threads instead of 1515 (243.12 KB, image/png)
2020-02-14 07:22 UTC, Philippe Mouawad
Details
Test Plan (48.84 KB, application/xml)
2020-02-14 07:23 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2020-02-14 07:22:42 UTC
Created attachment 37015 [details]
ActiveThreadsOverTime showing we have a plateau at 1159 Threads instead of 1515

If you add a DebugPostProcessor in the test plan and run a test, you end up with lines in CSV where number of threads and number of threads in Thread Group is equal to 0.
As a consequence this breaks the report Active Thread Over Time and any 3rd party plugin report that tries to compute this.


Workaround:

- Remove DebugPostProcessor

See attached Test plan
Comment 1 Philippe Mouawad 2020-02-14 07:23:09 UTC
Created attachment 37016 [details]
Test Plan
Comment 2 Philippe Mouawad 2020-02-14 07:38:02 UTC
pmouawad pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/jmeter.git

commit 8a02d4b485ddebefb47d18f2273046058cbadafe
Author: pmouawad <p.mouawad@ubik-ingenierie.com>
AuthorDate: Fri Feb 14 08:31:02 2020 +0100

    Bug 64142 - Presence of DebugPostProcessor in Test plan breaks
    ActiveThread Over time in report due to missing information
---
 .../main/java/org/apache/jmeter/extractor/DebugPostProcessor.java    | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
Comment 3 Felix Schumacher 2020-02-16 15:43:26 UTC
commit 99a06ac24d77fd15a1adf8bc25bbec5c77c40ea5
AuthorDate: Sun Feb 16 16:29:59 2020 +0100

    Seems like our test plans were subject to the bug 64142
    
    Correct the number of reported threads in the expected file, as they
    have changed with the fixing of bug 64142.
    
    Bugzilla Id: 64142
---
 bin/testfiles/JDBC_TESTS.xml | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
Comment 4 Philippe Mouawad 2020-03-07 18:13:02 UTC
*** Bug 64176 has been marked as a duplicate of this bug. ***