Bug 64150 - View Results Tree: Allow editing of response data in testers
Summary: View Results Tree: Allow editing of response data in testers
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.2.1
Hardware: All All
: P2 enhancement (vote)
Target Milestone: JMETER_5.3.0
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
: 63895 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-02-17 19:54 UTC by Philippe Mouawad
Modified: 2020-06-04 07:26 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2020-02-17 19:54:00 UTC
Use case:

- Some applications apply some obfuscation on response data (json, html, xml) and it cannot be handled anymore through Tests available in View Results Tree
- When you create a Test Plan, you are able through Post Processor to restore the original data so that data is in the original format(json, html, xml)
- This is very annoying during script building when you work based on recording as you cannot run tests on obfuscated data


This enhancement will let user edit the data to restore the original format and this way be able to work with data
Comment 1 Philippe Mouawad 2020-02-17 20:14:30 UTC
This is an automated email from the ASF dual-hosted git repository.

pmouawad pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/jmeter.git


The following commit(s) were added to refs/heads/master by this push:
     new 6907711  Bug 64150 - View Results Tree: Allow editing of response data in testers
6907711 is described below

commit 6907711f77404bebedd98a0b9b71f8a92833613d
Author: pmouawad <p.mouawad@ubik-ingenierie.com>
AuthorDate: Mon Feb 17 21:13:22 2020 +0100

    Bug 64150 - View Results Tree: Allow editing of response data in testers
---
 .../json/render/AbstractRenderAsJsonRenderer.java  |  2 +-
 .../visualizers/RenderAsBoundaryExtractor.java     | 17 ++++++---------
 .../jmeter/visualizers/RenderAsCssJQuery.java      | 18 ++++++----------
 .../apache/jmeter/visualizers/RenderAsRegexp.java  | 17 ++++++---------
 .../apache/jmeter/visualizers/RenderAsXPath.java   | 17 ++++++---------
 .../apache/jmeter/visualizers/RenderAsXPath2.java  | 25 +++++++++++-----------
 xdocs/changes.xml                                  |  1 +
 7 files changed, 42 insertions(+), 55 deletions(-)
Comment 2 Philippe Mouawad 2020-06-04 07:26:33 UTC
*** Bug 63895 has been marked as a duplicate of this bug. ***