Bug 64320 - Webpage freezes while sending a search request
Summary: Webpage freezes while sending a search request
Status: RESOLVED DUPLICATE of bug 64120
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 5.2.1
Hardware: PC All
: P3 blocker (vote)
Target Milestone: JMETER_5.3.0
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
Depends on:
Blocks:
 
Reported: 2020-04-07 11:33 UTC by Alexander
Modified: 2020-04-25 13:07 UTC (History)
2 users (show)



Attachments
short Jmeter log file (3.77 KB, text/plain)
2020-04-07 11:33 UTC, Alexander
Details
settings of encoding (7.46 KB, image/png)
2020-04-07 18:52 UTC, Alexander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2020-04-07 11:33:48 UTC
Created attachment 37152 [details]
short Jmeter log file

Hello!

I can not record a script.

The web page freezes while I type in the search bar

This happens with the Cyrillic and Latin letters.

Version Jmeter 5.2.1.

JRE Version 8 Update 241

Short information from Jmeter in log File.
Comment 1 Philippe Mouawad 2020-04-07 18:32:20 UTC
Hello,
Did you try setting in HTTP Test Script recorder encoding to UTF-8 or some encoding used by your app ?

Could you attach a screenshot of this element.
Regards
Comment 2 Alexander 2020-04-07 18:37:41 UTC
(In reply to Philippe Mouawad from comment #1)
> Hello,
> Did you try setting in HTTP Test Script recorder encoding to UTF-8 or some
> encoding used by your app ?
> 
> Could you attach a screenshot of this element.
> Regards

Yes i try it (encoding UTF-8)
Comment 3 Alexander 2020-04-07 18:50:07 UTC
(In reply to Alexander from comment #2)
> (In reply to Philippe Mouawad from comment #1)
> > Hello,
> > Did you try setting in HTTP Test Script recorder encoding to UTF-8 or some
> > encoding used by your app ?
> > 
> > Could you attach a screenshot of this element.
> > Regards
> 
> Yes i try it (encoding UTF-8)
Comment 4 Alexander 2020-04-07 18:50:28 UTC
(In reply to Alexander from comment #2)
> (In reply to Philippe Mouawad from comment #1)
> > Hello,
> > Did you try setting in HTTP Test Script recorder encoding to UTF-8 or some
> > encoding used by your app ?
> > 
> > Could you attach a screenshot of this element.
> > Regards
> 
> Yes i try it (encoding UTF-8)
Comment 5 Alexander 2020-04-07 18:52:03 UTC
Created attachment 37157 [details]
settings of encoding

its my settings of encoding.
Comment 6 Alexander 2020-04-07 18:56:21 UTC
(In reply to Philippe Mouawad from comment #1)
> Hello,
> Did you try setting in HTTP Test Script recorder encoding to UTF-8 or some
> encoding used by your app ?
> 
> Could you attach a screenshot of this element.
> Regards

When i use Loadrunner the symbols looks like "%u0410%u0410%u0410%u0410%u041"
Comment 7 Philippe Mouawad 2020-04-07 19:21:21 UTC
(In reply to Alexander from comment #6)
> (In reply to Philippe Mouawad from comment #1)
> > Hello,
> > Did you try setting in HTTP Test Script recorder encoding to UTF-8 or some
> > encoding used by your app ?
> > 
> > Could you attach a screenshot of this element.
> > Regards
> 
> When i use Loadrunner the symbols looks like "%u0410%u0410%u0410%u0410%u041"

Can you try also with nightly build 
https://ci.apache.org/projects/jmeter/nightlies/

If it still fails, can you add the failing request as it appears in browser network tab ?
You can right click and export as cURL

Thanks
Comment 8 Alexander 2020-04-08 07:56:56 UTC
(In reply to Philippe Mouawad from comment #7)
> (In reply to Alexander from comment #6)
> > (In reply to Philippe Mouawad from comment #1)
> > > Hello,
> > > Did you try setting in HTTP Test Script recorder encoding to UTF-8 or some
> > > encoding used by your app ?
> > > 
> > > Could you attach a screenshot of this element.
> > > Regards
> > 
> > When i use Loadrunner the symbols looks like "%u0410%u0410%u0410%u0410%u041"
> 
> Can you try also with nightly build 
> https://ci.apache.org/projects/jmeter/nightlies/
> 
> If it still fails, can you add the failing request as it appears in browser
> network tab ?
> You can right click and export as cURL
> 
> Thanks


The error is repeated.
The error text in the Jmeter console is the same. A response code of 200 is returned for all requests. For one of the requests, the response says 502 error method not imlemented probably use https isnstead http. But i use https. Can I replace the escape () function with another and how?
Comment 9 Alexander 2020-04-18 19:06:24 UTC
Java.lang.PIllegalArgumentException:URLDecoder:Illegal hex characters in escape (%) pattern - for input string u0
Comment 10 Philippe Mouawad 2020-04-25 13:06:22 UTC

*** This bug has been marked as a duplicate of bug 64120 ***