Bug 64354 - Transaction Controller in "Generate Parent Sample" mode : Failed assertions do not show in 'View Results Tree' when inside check for JMeterThread.last_sample_ok
Summary: Transaction Controller in "Generate Parent Sample" mode : Failed assertions d...
Status: RESOLVED DUPLICATE of bug 64589
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.2.1
Hardware: All All
: P2 major (vote)
Target Milestone: JMETER_5.3.0
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on: 57958
Blocks:
  Show dependency tree
 
Reported: 2020-04-15 17:15 UTC by Lionel Najman
Modified: 2020-07-26 11:59 UTC (History)
3 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Najman 2020-04-15 17:15:20 UTC
+++ This bug was initially created as a clone of Bug #57958 +++

In a test plan, there is a need to fire the logout step if login was successful no matter which intermediate step fails.

In the test plan, the value of JMeterThread.last_sample_ok was used in an if-controller with 'Evaluate for all children' turned on so that any failing step inside the if-controller will skip the remaining steps.

This technique works, however, when assertions fail inside this if-controller, they are not reported in the 'View Results Tree' as errors if 'Generate Parent Sample' is enabled.

I've exactly the same bug as #57958 with jmeter 5.1.1 and 5.2.1

I think this is a regression.

Can you confirm this?
Comment 1 Philippe Mouawad 2020-07-26 11:59:01 UTC

*** This bug has been marked as a duplicate of bug 64589 ***