Bug 64455 - Getting OutOfMemory Error while trying generate HTML report
Summary: Getting OutOfMemory Error while trying generate HTML report
Status: RESOLVED WONTFIX
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.2.1
Hardware: PC All
: P2 normal (vote)
Target Milestone: JMETER_5.4
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-19 18:21 UTC by Helen
Modified: 2020-07-11 12:52 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Helen 2020-05-19 18:21:26 UTC
I have JMeter script with SOAP API requests, which are placing a purchasing order. There are no issues during order creation time, but when all requests are finished and JMeter is trying to generate report I am getting an error:
java.lang.OutOfMemoryError: Java heap space
Dumping heap to java_pid8676.hprof ...
Heap dump file created [7011161840 bytes in 93.212 secs]
Uncaught Exception java.lang.OutOfMemoryError: Java heap space in thread Thread[StandardJMeterEngine,5,main]. See log file for details.
I used JConsole to monitor JMeter during execution and noticed that heap mostly was at 25% during test run and went up to 100% during report generation. Parameter in batch file set HEAP=-Xms1024m -Xmx7168m
Thanks in advance
Comment 1 Philippe Mouawad 2020-05-20 06:56:24 UTC
Hello,
Thank you for the report.
Can you share your CSV file, user.properties and the generated hprof file ?
Thank you
Comment 2 Felix Schumacher 2020-05-28 14:10:41 UTC
*** Bug 64475 has been marked as a duplicate of this bug. ***
Comment 3 Iliya Iliev 2020-05-28 19:59:11 UTC
(In reply to Felix Schumacher from comment #2)
> *** Bug 64475 has been marked as a duplicate of this bug. ***

Hello Felix,

I've tried to generate an HTML report. I'm using v 5.3
The following message was thrown:

*Generating report
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.thoughtworks.xstream.core.util.Fields (file:/C:/apache-jmeter-5.3/apache-jmeter-5.3/lib/xstream-1.4.11.1.jar) to field java.util.TreeMap.comparator
WARNING: Please consider reporting this to the maintainers of com.thoughtworks.xstream.core.util.Fields
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release*
Comment 4 Iliya Iliev 2020-05-28 20:02:58 UTC
When I am running the script in cli the desired 'report' folder passed as argument is completely empty.

The generated .jtl file is around 2gb.
I will be happy to help you out investigating the issue with providing you the .jtl file.
How could it be achieved?

Regards,
Iliya
Comment 5 Felix Schumacher 2020-06-02 14:27:04 UTC
Thanks Iliya for the jtl file. I ran it on my local machine and it didn't crash with OOM. Did you specify any heap settings on your runs?

@Helen, did your crash happen when creating a report (after a test run), or while running the test plan?
Comment 6 Iliya Iliev 2020-06-03 12:12:57 UTC
Hey Felix,

I did not change any heap settings.
Comment 7 Philippe Mouawad 2020-07-11 12:52:13 UTC
Issue was due to Test plan using an index for each request leading to thousands to hundred of thousands different transactions names.

As this is not the expected use of JMeter, closing this issue as WONTFIX.