Bug 64510 - Darklaf: IntelliJ Theme throws NPE in DarkTreeUI on MacOS java.lang.NullPointerException: null at com.github.weisj.darklaf.ui.tree.DarkTreeUI$2.actionPerformed
Summary: Darklaf: IntelliJ Theme throws NPE in DarkTreeUI on MacOS java.lang.NullPoint...
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.3
Hardware: PC Mac OS X 10.1
: P2 normal (vote)
Target Milestone: JMETER_5.4
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
Depends on:
Blocks:
 
Reported: 2020-06-10 09:46 UTC by Mohamed Ibrahim
Modified: 2020-07-29 06:39 UTC (History)
1 user (show)



Attachments
JMeter log reference (28.14 KB, text/plain)
2020-06-10 09:46 UTC, Mohamed Ibrahim
Details
NightlyBuild-JmeterLog (35.81 KB, text/plain)
2020-06-10 10:40 UTC, Mohamed Ibrahim
Details
Screenshot of IntelliJ theme error (838.78 KB, image/png)
2020-06-13 09:02 UTC, Mohamed Ibrahim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mohamed Ibrahim 2020-06-10 09:46:20 UTC
Created attachment 37300 [details]
JMeter log reference

Uncaught Exception java.lang.NullPointerException in thread Thread[AWT-EventQueue-0,6,main]. See log file for details.


2020-06-10 10:38:25,955 ERROR o.a.j.JMeter: Uncaught exception in thread Thread[AWT-EventQueue-0,6,main]
java.lang.NullPointerException: null
        at com.github.weisj.darklaf.ui.tree.DarkTreeUI$2.actionPerformed(DarkTreeUI.java:226) ~[darklaf-core-2.1.1.jar:2.1.1]
        at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1668) ~[?:1.8.0_211]
        at javax.swing.JComponent.processKeyBinding(JComponent.java:2882) ~[?:1.8.0_211]
        at javax.swing.JComponent.processKeyBindings(JComponent.java:2929) ~[?:1.8.0_211]
        at javax.swing.JComponent.processKeyEvent(JComponent.java:2845) ~[?:1.8.0_211]
        at java.awt.Component.processEvent(Component.java:6316) ~[?:1.8.0_211]
        at java.awt.Container.processEvent(Container.java:2239) ~[?:1.8.0_211]
        at java.awt.Component.dispatchEventImpl(Component.java:4889) ~[?:1.8.0_211]
        at java.awt.Container.dispatchEventImpl(Container.java:2297) ~[?:1.8.0_211]
        at java.awt.Component.dispatchEvent(Component.java:4711) ~[?:1.8.0_211]
        at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1954) ~[?:1.8.0_211]
        at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:835) ~[?:1.8.0_211]
        at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1103) ~[?:1.8.0_211]
        at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:974) ~[?:1.8.0_211]
        at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:800) ~[?:1.8.0_211]
        at java.awt.Component.dispatchEventImpl(Component.java:4760) ~[?:1.8.0_211]
        at java.awt.Container.dispatchEventImpl(Container.java:2297) ~[?:1.8.0_211]
        at java.awt.Window.dispatchEventImpl(Window.java:2746) ~[?:1.8.0_211]
        at java.awt.Component.dispatchEvent(Component.java:4711) ~[?:1.8.0_211]
        at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760) ~[?:1.8.0_211]
        at java.awt.EventQueue.access$500(EventQueue.java:97) ~[?:1.8.0_211]
        at java.awt.EventQueue$3.run(EventQueue.java:709) ~[?:1.8.0_211]
        at java.awt.EventQueue$3.run(EventQueue.java:703) ~[?:1.8.0_211]
        at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_211]
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74) ~[?:1.8.0_211]
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:84) ~[?:1.8.0_211]
        at java.awt.EventQueue$4.run(EventQueue.java:733) ~[?:1.8.0_211]
        at java.awt.EventQueue$4.run(EventQueue.java:731) ~[?:1.8.0_211]
        at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_211]
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74) ~[?:1.8.0_211]
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:730) ~[?:1.8.0_211]
        at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205) [?:1.8.0_211]
        at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116) [?:1.8.0_211]
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105) [?:1.8.0_211]
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101) [?:1.8.0_211]
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93) [?:1.8.0_211]
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:82) [?:1.8.0_211]
Comment 1 Philippe Mouawad 2020-06-10 09:52:22 UTC
Hello,
Can you try nightly build and tell if issue persists ?

Thank you
Comment 2 Philippe Mouawad 2020-06-10 09:52:33 UTC
(In reply to Philippe Mouawad from comment #1)
> Hello,
> Can you try nightly build and tell if issue persists ?
> 
> Thank you
From here:
https://ci.apache.org/projects/jmeter/nightlies/
Comment 3 Mohamed Ibrahim 2020-06-10 10:40:10 UTC
Created attachment 37301 [details]
NightlyBuild-JmeterLog
Comment 4 Mohamed Ibrahim 2020-06-10 10:40:29 UTC
I see the same issue with Nightly build as well.
Comment 5 Philippe Mouawad 2020-06-12 11:37:31 UTC
Hello,
Thanks for testing.

Can you provide the following please:

- How to reproduce this ? what do you do ?
- What happens in the UI ?Error , something not displayed ..
- Screenshots if possible

Once done, I'll open an issue to related library.

Thank you
Regards
Comment 6 Mohamed Ibrahim 2020-06-13 09:02:03 UTC
Steps to reproduce:

1. Download the Jmeter-5.3, extract it.
2. Open the Jmeter and set the look and feel to Darklaf-IntelliJ
3. Open any script
4. Try to expand the threadgroup
5. The log will have the exception

There is no error displayed on the UI and the functionality didn't break.

Attached the screenshot as well.
Comment 7 Mohamed Ibrahim 2020-06-13 09:02:51 UTC
Created attachment 37311 [details]
Screenshot of IntelliJ theme error
Comment 8 Philippe Mouawad 2020-06-13 16:53:15 UTC
This should be fixed by upgrade to next version of darklaf > 2.2.3 but for now due to other regressions in Darklaf I cannot upgrade:

- https://github.com/weisJ/darklaf/issues/182

Waiting for:
https://github.com/weisJ/darklaf/issues/184