Bug 64657 - The remote test failed in cli mode, but succeeded in Gui mode.
Summary: The remote test failed in cli mode, but succeeded in Gui mode.
Status: CLOSED INVALID
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 5.3
Hardware: PC All
: P2 normal (vote)
Target Milestone: JMETER_5.4
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-10 08:03 UTC by fengziting
Modified: 2020-08-10 14:25 UTC (History)
0 users



Attachments
jmeter.log (13.59 KB, text/plain)
2020-08-10 08:03 UTC, fengziting
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fengziting 2020-08-10 08:03:48 UTC
Created attachment 37387 [details]
jmeter.log

First,I have copied the file bin/rmi_keystore.jks to every JMeter server and client I want to use.
Then I run the remote test in GUI mode and the test result is successful.
When I run in CLI mode, CMD prompts an error, such as jmeter.log :
2020-08-10 15:49:54,226 ERROR o.a.j.u.JMeterUtils: Exception creating connection to: 192.168.28.118; nested exception is: 
java.io.FileNotFoundException: rmi_keystore.jks
Comment 1 Felix Schumacher 2020-08-10 10:00:41 UTC
This seems to be a question about the usage of JMeter. Such questions should be asked no the users mailing list. See https://jmeter.apache.org/mail2.html on how to subscribe and send mails.

The keystore is located by looking at the JMeter properties 

server.rmi.ssl.keystore.file=rmi_keystore.jks
server.rmi.ssl.truststore.file=rmi_keystore.jks

As you can see, they are given relative and when you start JMeter via GUI, I assume, that you are starting JMeter from inside the bin/ folder. That way JMeter finds the keystore, as it is insde the bin/ folder, too.

If you start JMeter from the CLI via ./bin/jmeter.sh (or equvialent), you are not in the bin/ folder and JMeter will not find the keystore.