Bug 64691 - A private field name suggestion (org.apache.poi.xssf.usermodel.XSSFDataValidation.ctDdataValidation->org.apache.poi.xssf.usermodel.XSSFDataValidation.ctDataValidation)
Summary: A private field name suggestion (org.apache.poi.xssf.usermodel.XSSFDataValida...
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: SS Common (show other bugs)
Version: unspecified
Hardware: PC All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-27 07:09 UTC by asdf913
Modified: 2020-10-25 04:37 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description asdf913 2020-08-27 07:09:31 UTC
It is suggested that the field "ctDdataValidation" could be renamed as "ctDataValidation"

https://github.com/apache/poi/blob/trunk/src/ooxml/java/org/apache/poi/xssf/usermodel/XSSFDataValidation.java#L41

public class XSSFDataValidation implements DataValidation {
    private CTDataValidation ctDdataValidation;
}
Comment 1 PJ Fanning 2020-08-27 12:38:27 UTC
Thanks for pointing this out. I used https://github.com/apache/poi/commit/f89528addc51729a438eb5732129b87c2d87b4b9 to tidy this up.
Comment 2 Dominik Stadler 2020-10-25 04:37:25 UTC
Why REOPEN? Seems to be resolved, if not then please describe why.