Bug 64787 - Korean translations
Summary: Korean translations
Status: CLOSED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.3
Hardware: PC Mac OS X 10.1
: P2 normal (vote)
Target Milestone: JMETER_5.4
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
Depends on:
Blocks:
 
Reported: 2020-10-06 04:31 UTC by Woonsan Ko
Modified: 2020-10-11 16:48 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Woonsan Ko 2020-10-06 04:31:18 UTC
Korean translation resources for UI, messages, etc.
I'll provide a pull request soon.
Comment 1 Woonsan Ko 2020-10-09 03:07:45 UTC
PR ready for review:
- https://github.com/apache/jmeter/pull/630
Comment 2 Felix Schumacher 2020-10-11 09:59:57 UTC
I had to use OpenJDK on my ubuntu machine to get the Korean characters displayed, but that it looked great (even if I can't read anything ;) ).

There seem to be missing the keys for html_report, compile_jsr223, schematic_view and import_curl. If would be great, if someone could add those, too.

@Woonsan could you test the next nightly and close this bug, if it still works for you?
Comment 3 Woonsan Ko 2020-10-11 14:22:06 UTC
Hello Felix,

Thank you so much for quick reviews and merging it! I am also very happy especially as it was done on Hangul Day (https://en.wikipedia.org/wiki/Hangul_Day). ;-)

Regarding the issue with the 4 menu items under the "Tools", I've just filed another ticket: https://bz.apache.org/bugzilla/show_bug.cgi?id=64800. When I saw it before, I thought it was a known issue.
Anyway, I'll try to find the root cause with the ticket and come back to share the findings.

Thanks,

Woonsan
Comment 4 Woonsan Ko 2020-10-11 16:47:48 UTC
I've suggested a PR to fix those some wrong tools menu item label issues (https://bz.apache.org/bugzilla/show_bug.cgi?id=64800).
And, everything is working fine with Korean language after merging. I'm closing this. Thanks again!