Bug 64950 - about doughnutchart
Summary: about doughnutchart
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: XWPF (show other bugs)
Version: 4.1.2-FINAL
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords: PatchAvailable
: 64992 (view as bug list)
Depends on:
Blocks: 64992
  Show dependency tree
 
Reported: 2020-12-02 08:24 UTC by wu
Modified: 2021-01-21 21:14 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wu 2020-12-02 08:24:23 UTC
when i use this version.
i can't create a XDDFoughnutChartData instance with the method of 'createData(...) ' which in the class of XDDFChart


in other way.
when i create a CTDoughnutChart instance with XDDFChart.getCTChart().getPlotArea().getDoughnutChartArray(0);
i can't call the method of setHoleSize(...), because there is not class definition of CTHoleSize

if i don't use the setHoleSize  , the result of the program is a pie chart.
Comment 1 Dominik Stadler 2020-12-10 20:39:43 UTC
A PR for this is at https://github.com/apache/poi/pull/201/, you can help this by testing this, you can take the artifacts produced in a test-build at https://ci-builds.apache.org/job/POI/job/POI-DSL-Github-PullRequests/1/artifact/build/dist/
Comment 2 PJ Fanning 2020-12-16 09:16:21 UTC
*** Bug 64992 has been marked as a duplicate of this bug. ***
Comment 3 Alain Fagot Bearez 2021-01-19 04:02:06 UTC
The pull request at https://github.com/apache/poi/pull/201/ is now providing the expected behaviour to set the hole size.

I am still working to make the chart creation from scratch produce a file which opens with PowerPoint, as it currently only opens with LibreOffice.
Comment 4 Alain Fagot Bearez 2021-01-21 21:14:55 UTC
fixed by r1885771