Bug 64993 - Daklaf LAF: Menu navigation not working with keyboard shortcuts
Summary: Daklaf LAF: Menu navigation not working with keyboard shortcuts
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.4
Hardware: PC All
: P2 regression (vote)
Target Milestone: JMETER 5.4.1
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
Depends on:
Blocks:
 
Reported: 2020-12-16 10:30 UTC by Sumit Khaitan
Modified: 2020-12-21 16:15 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sumit Khaitan 2020-12-16 10:30:43 UTC
In earlier versions of JMeter by pressing ALT-F and then E on the keyboard it used to navigate to "Open Recent" sub-menu under File menu.
This is not working with latest version of JMeter 5.4 and is true for all other sub-options
Comment 1 Philippe Mouawad 2020-12-19 17:55:19 UTC
Opened:

https://github.com/weisJ/darklaf/issues/227
Comment 2 Philippe Mouawad 2020-12-20 20:03:12 UTC
pmouawad pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/jmeter.git


The following commit(s) were added to refs/heads/master by this push:
     new b9cdab0  Daklaf LAF: Menu navigation not working with keyboard shortcuts
b9cdab0 is described below

commit b9cdab0b5dd92a39a9b7a375047744bb82fe3f4f
Author: pmouawad <p.mouawad@ubik-ingenierie.com>
AuthorDate: Sun Dec 20 21:02:16 2020 +0100

    Daklaf LAF: Menu navigation not working with keyboard shortcuts
---
 gradle.properties                           |  2 +-
 src/dist/src/dist/expected_release_jars.csv | 16 ++++++++--------
 xdocs/changes.xml                           |  1 +
 3 files changed, 10 insertions(+), 9 deletions(-)
Comment 3 Philippe Mouawad 2020-12-20 20:40:06 UTC
(In reply to Sumit Khaitan from comment #0)
> In earlier versions of JMeter by pressing ALT-F and then E on the keyboard
> it used to navigate to "Open Recent" sub-menu under File menu.
> This is not working with latest version of JMeter 5.4 and is true for all
> other sub-options

Hello,
Issue should be fixed now, I tested on Windows and it works for me.

Could you test on your side using nightly build:

- https://ci-builds.apache.org/job/JMeter/job/JMeter-trunk/

Thanks
Comment 4 Sumit Khaitan 2020-12-20 20:49:59 UTC
Looks good to me also. Any idea by when it will be officially released
Comment 5 Sumit Khaitan 2020-12-21 09:03:24 UTC
hi, found another issue (mostly related) while using keypboard arrows to navigate through tree view, left and right arrows are behaving like up-down arrows. Should jump to the parent element but just goes one up within the same parent.
This is not an issue with WIndows Classic "look and feel"
Comment 6 Philippe Mouawad 2020-12-21 16:13:53 UTC
Hello, 
I'll create another ticket as it's a different issue.

Thanks
Comment 7 Philippe Mouawad 2020-12-21 16:15:12 UTC
Hello,
Can you confirm this is what you are facing: 

https://bz.apache.org/bugzilla/show_bug.cgi?id=65017 (see the Darklaf bug report).

Thanks