Bug 64994 - Sending HTTP Request Name to Jenkins Performance Plugin even though it is under "Transaction Controller" with "Generate Parent Sample" enabled
Summary: Sending HTTP Request Name to Jenkins Performance Plugin even though it is und...
Status: NEW
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 5.4
Hardware: PC All
: P2 normal (vote)
Target Milestone: JMETER 5.4.1
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-16 10:45 UTC by Sumit Khaitan
Modified: 2021-01-05 10:15 UTC (History)
2 users (show)



Attachments
More Details (259.25 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-12-16 10:45 UTC, Sumit Khaitan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sumit Khaitan 2020-12-16 10:45:21 UTC
Created attachment 37620 [details]
More Details

In earlier versions of JMeter, if Transaction Controller with "Generate Parent Sample" enabled used to send only Transaction Controller related details to Jenkins Performance Plugin.
However, with JMeter 5.4 it is sending HTTP requests as well (behaving like Generate Parent Sample is unchecked)
Comment 1 Philippe Mouawad 2020-12-19 16:31:48 UTC
If XML is used, Generate parent sampler will deliver a parent element with children.
Are you sure you're not in this configuration ?

Could you check the output you're using and see if in the CSV (if it's CSV) output you have a trace of the children of this transaction controller ?


Thank you
Comment 2 Sumit Khaitan 2020-12-19 16:44:22 UTC
Only Backend Listener is added to the script and below is the non-GUI statement

jmeter -n -f -t "<script_location.jmx>" -l <log_path.jtl>

Yes, since Jmeter 5.4 .jtl file is having child HTTP requests as well. I have checked older jtl files and they used to have only "Transaction Controller" details

Nothing has changed other than Jmeter version
Comment 3 Sumit Khaitan 2020-12-22 11:22:02 UTC
Another behaviour, only one HTTP Request with "follow redirect" enabled and no Transaction controller:-
HTTP Request name "T12_ServiceSssInfo_AllNodes_CR_10strWk" is being stored as "T12_ServiceSssInfo_AllNodes_CR_10strWk-0" for 302 HTTP Code and "T12_ServiceSssInfo_AllNodes_CR_10strWk-1" for 200 HTTP Code

Part of XML log for reference:-
<httpSample t="55" it="0" lt="14" ct="4" ts="1608633726221" s="false" lb="T12_ServiceSssInfo_AllNodes_CR_10strWk" rc="200" rm="OK" tn="PiePSS 1-1" dt="text" by="2354" sby="3926" ng="50" na="50">
  <assertionResult>
    <name>Response Assertion</name>
    <failure>true</failure>
    <error>false</error>
    <failureMessage>Test failed: text expected to contain /partStructureNodeList/</failureMessage>
  </assertionResult>
  <httpSample t="14" it="0" lt="14" ct="4" ts="1608633726221" s="true" lb="T12_ServiceSssInfo_AllNodes_CR_10strWk-0" rc="302" rm="Found" tn="PiePSS 1-1" dt="" by="677" sby="2395" ng="50" na="50"/>
  <httpSample t="38" it="0" lt="37" ct="21" ts="1608633726238" s="true" lb="T12_ServiceSssInfo_AllNodes_CR_10strWk-1" rc="200" rm="OK" tn="PiePSS 1-1" dt="text" by="1677" sby="1531" ng="50" na="50"/>
</httpSample>
Comment 4 Sunny Agrawal 2020-12-26 07:45:55 UTC
Can you try by configuring the result file creation by clicking on save as XML under the configure button before the test run.
Comment 5 Sumit Khaitan 2021-01-05 10:15:59 UTC
Tried and it's the same behaviour. Did you tried to replicate it at your end