Bug 65040 - Cell IFERROR don't work with other formula cells with POI
Summary: Cell IFERROR don't work with other formula cells with POI
Status: NEEDINFO
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 4.1.2-FINAL
Hardware: PC All
: P2 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-29 16:16 UTC by Yiao SUN
Modified: 2021-01-19 14:46 UTC (History)
0 users



Attachments
IFERROR Example (19.02 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-12-29 16:16 UTC, Yiao SUN
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yiao SUN 2020-12-29 16:16:02 UTC
Created attachment 37667 [details]
IFERROR Example

When I want to evaluate the formula cell with IFERROR cell, it don't work.

I attached a example Excel File			
Ex.
In sheet 1 I got
A2 Cell with IFERROR
=IFERROR(SUM(B2,B3,"Some Error Here",aetezt);0)

In sheet2 
I use this IFERROR cell to do a SUM in cell A2:
=SOMME(Sheet1!A2,Sheet1!C2,Sheet1!C3)

POI can't return the result of sheet2 A2 correctly:
Value Actual with POI : 0
Expected Value : 7


Could you please check this and correct it please ?


Best regards,
Yiao SUN
Comment 1 Yiao SUN 2021-01-19 14:46:11 UTC
my college added tests and example in ticket https://bz.apache.org/bugzilla/show_bug.cgi?id=65058
and 
https://bz.apache.org/bugzilla/show_bug.cgi?id=65059