Bug 65076 - Issue with passing AuthCookie due to AzureGatewayAffinityCors in Azure Environment
Summary: Issue with passing AuthCookie due to AzureGatewayAffinityCors in Azure Enviro...
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 5.2.1
Hardware: PC All
: P2 critical (vote)
Target Milestone: JMETER 5.4.1
Assignee: JMeter issues mailing list
URL: https://ecp2.demoemodal.com
Depends on:
Reported: 2021-01-12 16:11 UTC by Kumar K
Modified: 2021-03-06 09:39 UTC (History)
0 users

Failed call request (210.69 KB, image/png)
2021-01-12 16:11 UTC, Kumar K

Note You need to log in before you can comment on or make changes to this bug.
Description Kumar K 2021-01-12 16:11:52 UTC
Created attachment 37702 [details]
Failed call request

Getting 500 Internal Server error and 401-Unauthorized error for few calls when i hit the script in Azure environment. Same script is working fine when I run in  other environment.
We are passing below cookies dynamically along with AuthCookie, but for few calls below cookie only passing but not Authcookie and these calls are failing
When I run with multiple users, each time it is failing different calls.
Comment 1 Felix Schumacher 2021-01-12 18:38:00 UTC
I think this is better suited to be discussed on the users mailing list.

If you want to report an error, make sure to give enough details for us to reproduce the issue. See "Required Information for bug reporting" on https://jmeter.apache.org/issues.html for some hints.
Comment 2 Kumar K 2021-01-13 09:43:58 UTC
I am passing AuthCookie from common Header Manager for every call along with ApplicationGatewayAffinity cookies. For few calls AuthCookie is not passing and those calls are failing.
Please let me know if any further information is required.
Comment 3 Felix Schumacher 2021-03-06 09:39:39 UTC
A minimal test plan, that can be used to re-produce the issue would be fine.

If you can't provide a working example, try to attach a test plan, that shows the general set-up you are using. With the given information, I can't understand, what you are trying to do.