Bug 65109 - jmeter cli command create infinity folders of report
Summary: jmeter cli command create infinity folders of report
Alias: None
Product: JMeter - Now in Github
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 5.4.1
Hardware: PC All
: P2 normal with 1 vote (vote)
Target Milestone: JMETER 5.4.1
Assignee: JMeter issues mailing list
Depends on:
Reported: 2021-01-27 08:21 UTC by adiorgad100
Modified: 2022-02-20 20:16 UTC (History)
2 users (show)

Add markup for placeholders (20.56 KB, patch)
2021-01-27 18:42 UTC, Felix Schumacher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description adiorgad100 2021-01-27 08:21:53 UTC
I tried to run jmx file with following command: jmeter -n -t test.jmx -l <file.jtl location> -e -o <jmeter_report location>
and more than 400 report folders are created
pls note I tried it with your example jmx file
Comment 1 Felix Schumacher 2021-01-27 16:19:56 UTC
We have to update the documentation to make it even more clear, that <something> means, that you have to replace that thing with your intended value.

The problem with angled brackets is, the shell will interpret those as redirection parameters, which can do the wrong thing.
Comment 2 Felix Schumacher 2021-01-27 18:42:56 UTC
Created attachment 37721 [details]
Add markup for placeholders

With this patch the placeholders will not be marked with <..> but can instead be decorated with CSS. I have included two different styles (one for the printable and one for the web site). I am not really happy with both of them. But this could be used for a start.
Comment 3 adiorgad100 2021-01-27 19:22:53 UTC
Comment on attachment 37721 [details]
Add markup for placeholders

sorry but you didn't understand me the command I ran is: jmeter -g testresults.jtl -o C:\Users\adi\Documents\automation\output\reporting2 (I added <> here just for path value) and this command created in my pc a lot of report folders .
I did same command in 5.4 and it ran properly.
pls test it again
Comment 4 Felix Schumacher 2021-02-06 10:36:54 UTC
Sorry, for mis-reading your description. Can you show us, which folders where generated?

Also, it is always a good idea to give as much information on your environment as possible. Which JVM, OS, JMeter version? A sample JTL which can be used to reproduce the issue.
Comment 5 Philippe Mouawad 2022-02-20 20:16:05 UTC
Any update ?
We are not able to reproduce this bug.

Thank you
Comment 6 The ASF infrastructure team 2022-09-24 20:38:21 UTC
This issue has been migrated to GitHub: https://github.com/apache/jmeter/issues/5494