Bug 65202 - Have no write access for JMeter directories, not possible to use Plugins Manager
Summary: Have no write access for JMeter directories, not possible to use Plugins Manager
Status: RESOLVED INFORMATIONPROVIDED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.2.1
Hardware: PC All
: P2 normal (vote)
Target Milestone: JMETER_5.5
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-24 02:31 UTC by wuwenwen
Modified: 2021-06-06 14:14 UTC (History)
0 users



Attachments
An error page (91.89 KB, image/png)
2021-03-24 02:31 UTC, wuwenwen
Details
File directory permissions (32.64 KB, image/png)
2021-03-24 02:41 UTC, wuwenwen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wuwenwen 2021-03-24 02:31:13 UTC
Created attachment 37783 [details]
An error page

java.lang.RuntimeException: Cannot apply changes: Have no write access for JMeter directories, not possible to use Plugins Manager: D:\jmeter ant jenkins\apache-jmeter-5.2.1\lib\ext
	at org.jmeterplugins.repository.PluginManager.applyChanges(PluginManager.java:158) ~[jmeter-plugins-manager-1.4.jar:?]
	at org.jmeterplugins.repository.PluginManagerDialog$4.run(PluginManagerDialog.java:226) ~[jmeter-plugins-manager-1.4.jar:?]
Caused by: java.nio.file.AccessDeniedException: Have no write access for JMeter directories, not possible to use Plugins Manager: D:\jmeter ant jenkins\apache-jmeter-5.2.1\lib\ext
	at org.jmeterplugins.repository.PluginManager.checkRW(PluginManager.java:121) ~[jmeter-plugins-manager-1.4.jar:?]
	at org.jmeterplugins.repository.PluginManager.applyChanges(PluginManager.java:156) ~[jmeter-plugins-manager-1.4.jar:?]
	... 1 more
Comment 1 wuwenwen 2021-03-24 02:41:49 UTC
Created attachment 37784 [details]
File directory permissions
Comment 2 Felix Schumacher 2021-06-06 14:14:23 UTC
The PluginManager is not part of JMeter directly, but a third party plugin. If I understood the code from PluginManager correctly it looks for the location of one class to determine where the jars should be downloaded. So for this issue to be resovled, you would have to change that.

After that, you will probably have to adapt the JMeter property search_paths.