Bug 65228 - the method getCap() does not work correctly in xslf.usermodel.XSLFTextRun
Summary: the method getCap() does not work correctly in xslf.usermodel.XSLFTextRun
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: XSLF (show other bugs)
Version: 4.1.2-FINAL
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 65507 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-04-09 07:27 UTC by Stas
Modified: 2021-08-20 20:17 UTC (History)
2 users (show)



Attachments
Test file with capitalized text (325.31 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2021-04-09 07:27 UTC, Stas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stas 2021-04-09 07:27:13 UTC
Created attachment 37803 [details]
Test file with capitalized text

The test file contains the CAPITAL text. When trying to parse this file, the method getCap() always returns NONE, and the text itself is perceived as normal.

Expected result: the inscription in the file is recognized as MARZ.
Actual result: the inscription in the file is recognized as Marz.
Comment 1 Andreas Beeker 2021-04-22 22:10:54 UTC
Thank you for bringing this up - fixed via r1889111
Comment 2 Andreas Beeker 2021-08-20 20:17:02 UTC
*** Bug 65507 has been marked as a duplicate of this bug. ***