Bug 65252 - SSLOptions StrictRequire documentation
Summary: SSLOptions StrictRequire documentation
Status: NEW
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Documentation (show other bugs)
Version: 2.4.39
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: HTTP Server Documentation List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-20 01:03 UTC by Christoph Anton Mitterer
Modified: 2021-04-20 01:03 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Anton Mitterer 2021-04-20 01:03:13 UTC
1) The documentation for StrictRequire still uses the legacy Satisfy directive.

2) Thus, it's no even clear, whether StrictRequire applies really only to mod_access_compat's Satisfy... or also the the new Require/RequireAny/etc., or not.
I.e. would e.g. a
SSLRequireSSL
<RequireAny>
   Require all granted
</RequireAny>
be still affectde by StrictRequire, just in the same sense as with Satisfy?

3) It's further not clear, whether "Require ssl" is also affected by this