Bug 65277 - org.apache.coyote.ajp.AjpProcessor.service Error processing request java.lang.NullPointerException
Summary: org.apache.coyote.ajp.AjpProcessor.service Error processing request java.lan...
Status: RESOLVED INVALID
Alias: None
Product: Tomcat 9
Classification: Unclassified
Component: Connectors (show other bugs)
Version: 9.0.7
Hardware: PC Linux
: P2 major (vote)
Target Milestone: -----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-29 18:15 UTC by saranya
Modified: 2021-05-04 06:16 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description saranya 2021-04-29 18:15:54 UTC
SEVERE [ajp-nio-8109-exec-244] org.apache.coyote.ajp.AjpProcessor.service Error processing request
 java.lang.NullPointerException
	at org.apache.catalina.connector.Request.notifyAttributeAssigned(Request.java:1544)
	at org.apache.catalina.connector.Request.setAttribute(Request.java:1530)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:147)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:92)
	at org.apache.catalina.valves.AbstractAccessLogValve.invoke(AbstractAccessLogValve.java:651)
	at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:291)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:87)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:343)
	at org.apache.coyote.ajp.AjpProcessor.service(AjpProcessor.java:394)
	at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:66)
	at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:764)
	at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1379)
	at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
	at java.lang.Thread.run(Thread.java:748)

29-Apr-2021 11:31:59.560 SEVERE [ajp-nio-8109-exec-969] org.apache.catalina.core.StandardHostValve.invoke Exception Processing null
 java.lang.NullPointerException
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:236)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:96)
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:608)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:139)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:92)
	at org.apache.catalina.valves.AbstractAccessLogValve.invoke(AbstractAccessLogValve.java:651)
	at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:291)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:87)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:343)
	at org.apache.coyote.ajp.AjpProcessor.service(AjpProcessor.java:394)
	at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:66)
	at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:764)
	at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1379)
	at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
	at java.lang.Thread.run(Thread.java:748)

WARNING [main] org.apache.catalina.startup.SetAllPropertiesRule.begin [SetAllPropertiesRule]{Server/Service/Connector} Setting property 'server' to ' ' did not find a matching property.
29-Apr-2021 11:31:59.607 SEVERE [ajp-nio-8109-exec-977] org.apache.catalina.core.StandardHostValve.invoke Exception Processing null
 java.lang.NullPointerException
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:236)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:96)
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:608)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:139)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:92)
	at org.apache.catalina.valves.AbstractAccessLogValve.invoke(AbstractAccessLogValve.java:651)
	at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:291)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:87)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:343)
	at org.apache.coyote.ajp.AjpProcessor.service(AjpProcessor.java:394)
	at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:66)
	at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:764)
	at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1379)
	at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
	at java.lang.Thread.run(Thread.java:748)
Comment 1 Remy Maucherat 2021-04-30 09:20:00 UTC
Please test with a newer version of Tomcat 9, and also explain how to reproduce the issue if it actually occurs.
Comment 2 Mark Thomas 2021-04-30 09:33:20 UTC
The line numbers in the first stack trace do not match with the reported version. The SetAllPropertiesRule error also looks strange.
Comment 3 saranya 2021-04-30 16:39:45 UTC
(In reply to Remy Maucherat from comment #1)
> Please test with a newer version of Tomcat 9, and also explain how to
> reproduce the issue if it actually occurs.

@Remy: Thanks for the reply. This happens only in Production server. Hence upgarding to new version is not possible immediately.

>The issue occurs when multiple users access the application and try downloading files and uploading at same time.

> Also in DB(Oracle 18C) the process and session keeps increasing.
 
Please assist me.
Comment 4 Mark Thomas 2021-05-03 20:35:15 UTC
This looks like an application issue (retaining and using a reference to the request and/or response after the processing of that request/response has completed).

The increasing database connections indicate that the application also has a connection leak.

The users mailing list is the place to ask for help with those types of issues.
Comment 5 saranya 2021-05-04 06:16:21 UTC
(In reply to Mark Thomas from comment #4)
> This looks like an application issue (retaining and using a reference to the
> request and/or response after the processing of that request/response has
> completed).
> 
> The increasing database connections indicate that the application also has a
> connection leak.
> 
> The users mailing list is the place to ask for help with those types of
> issues.


Thanks Mark for replying!
But this issue occurs only after upgrading to Tomcat 9 from Tomcat 7. Also with same Tomcat 9 in TEST environment even after Load test the Oracle session and Process remains same.
Please throw some light on this:(