Bug 65382 - Silent installation fails
Summary: Silent installation fails
Status: RESOLVED WORKSFORME
Alias: None
Product: Tomcat 10
Classification: Unclassified
Component: Packaging (show other bugs)
Version: 10.0.6
Hardware: PC All
: P2 normal (vote)
Target Milestone: ------
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-15 20:26 UTC by Jake Shackelford
Modified: 2021-06-16 12:46 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jake Shackelford 2021-06-15 20:26:59 UTC
Using /S command during install with 10.0.6 fails if a new installation, if a previous version is installed it installs successfully.
Comment 1 Mark Thomas 2021-06-16 08:17:53 UTC
My guess would be that the installer can't find a Java installation.

To find out why the install fails, run the installer without the /S option and use the defaults all the way through.

Further assistance is available from the users@tomcat.apache.org mailing list
Comment 2 Jake Shackelford 2021-06-16 12:29:11 UTC
Installing it manually works fine and doesn't error out. In this case Java was not installed however /S worked on the 10.0.4 version.
Comment 3 Remy Maucherat 2021-06-16 12:46:52 UTC
Please do not reopen the report without giving useful new information and try the mailing list as suggested. There has been no change to the install script since 10.0.4, and no NSIS update so no possible regression.
This also works fine for me on my test system: fails without a JVM, works with it.