Bug 65469 - View result table sampler is not working properly.
Summary: View result table sampler is not working properly.
Status: NEEDINFO
Alias: None
Product: JMeter - Now in Github
Classification: Unclassified
Component: Main (show other bugs)
Version: 5.4.1
Hardware: PC All
: P2 major (vote)
Target Milestone: JMETER_5.5
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-28 10:44 UTC by Lerose
Modified: 2021-10-18 09:13 UTC (History)
0 users



Attachments
Highlighted the issue in screenshot (211.61 KB, image/png)
2021-07-28 10:44 UTC, Lerose
Details
View results in table UI issue (218.04 KB, text/plain)
2021-10-04 08:43 UTC, Lerose
Details
Screenshots (420.23 KB, image/jpeg)
2021-10-04 08:46 UTC, Lerose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lerose 2021-07-28 10:44:43 UTC
Created attachment 37970 [details]
Highlighted the issue in screenshot

Issue description
When user click on the "View result table" not able to see the table.

And I'm getting the "Null pointer exception" in console (Screenshots attached)
Comment 1 Felix Schumacher 2021-08-07 10:17:57 UTC
Can you post a minimal test plan, that reproduces this issue?

Are there any other error messages in the jmeter.log file?
Comment 2 Lerose 2021-10-04 08:42:58 UTC
(In reply to Felix Schumacher from comment #1)
> Can you post a minimal test plan, that reproduces this issue?
> 
> Are there any other error messages in the jmeter.log file?

Hi Felix,
    I have attached the log file. If I execute the test with minimal test plan I'm getting the UI issue.
Comment 3 Lerose 2021-10-04 08:43:56 UTC
Created attachment 38055 [details]
View results in table UI issue
Comment 4 Lerose 2021-10-04 08:46:44 UTC
Created attachment 38056 [details]
Screenshots
Comment 5 Felix Schumacher 2021-10-04 10:27:01 UTC
Can you try out another LAF?

Did you re-arrange the table in the results table view before switching to the tree view?
Comment 6 Felix Schumacher 2021-10-04 10:30:34 UTC
And can you try a current nightly?
Comment 7 Lerose 2021-10-05 08:47:23 UTC
I have tried with current nightly build as well facing same issue. "apache-jmeter-5.5-SNAPSHOT" build which i have used from this link https://ci-builds.apache.org/job/JMeter/job/JMeter-trunk/lastSuccessfulBuild/artifact/src/dist/build/distributions/
Comment 8 Felix Schumacher 2021-10-05 16:40:49 UTC
Have you tried switching the LAF?
Comment 9 Lerose 2021-10-06 10:15:59 UTC
I don't know what is LAF. Can you please explain in detail
Comment 10 Felix Schumacher 2021-10-07 19:24:54 UTC
LAF means Look And Feel. See
https://jmeter.apache.org/usermanual/properties_reference.html#laf_config for more information and how to change it.

Apart from changing the LAF. What version of the JDK are you using? Does it happen without the pluginmanager? Which language have you selected?

Looking for similar reports on the net, I found an old JDK bug on Windows: https://bugs.openjdk.java.net/browse/JDK-6429812 which might be related.
Comment 11 Lerose 2021-10-18 09:13:18 UTC
Hi Felix Schumacher 
    If I use "Darcula" theme able to see the view result in table properly.

Thanks
Lerose
Comment 12 The ASF infrastructure team 2022-09-24 20:38:22 UTC
This issue has been migrated to GitHub: https://github.com/apache/jmeter/issues/5562