Bug 65579 - after run jmeter, click clear all button, The log shows NullPointerException
Summary: after run jmeter, click clear all button, The log shows NullPointerExcep...
Status: RESOLVED CLOSED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: Nightly (Please specify date)
Hardware: PC All
: P2 normal (vote)
Target Milestone: JMETER_5.5
Assignee: JMeter issues mailing list
URL:
Keywords: FixedInTrunk
Depends on:
Blocks:
 
Reported: 2021-09-17 13:37 UTC by chazhongbao
Modified: 2021-09-18 11:00 UTC (History)
0 users



Attachments
error log (6.05 KB, text/plain)
2021-09-17 13:37 UTC, chazhongbao
Details
Test script (12.02 KB, application/xml)
2021-09-17 13:43 UTC, chazhongbao
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chazhongbao 2021-09-17 13:37:38 UTC
Created attachment 38035 [details]
error  log

1. Start jemter
2. Click the run button
3. Click the Clean All button
Expected result: the log displays correctly
Actual result: the log prompts NullPointerException

Environmental description:
jmeter version: daily build (2021-09-17)
java version:
java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

Operating system version:
Version Windows 10 Home Chinese Version
Version number 21H1
Installation date ‎2021/‎8/‎1
Operating system internal version 19043.1165
Serial number YX029CKY
Experience Windows Feature Experience Pack 120.2212.3530.0
Comment 1 chazhongbao 2021-09-17 13:40:15 UTC
Created attachment 38036
Comment 2 chazhongbao 2021-09-17 13:43:19 UTC
Created attachment 38037 [details]
Test script

This is the correct script, please ignore the previously submitted script
Comment 3 chazhongbao 2021-09-17 13:48:24 UTC
Comment on attachment 38036


Please help me delete this file, which contains private information, thank you.
Comment 4 Felix Schumacher 2021-09-17 15:41:39 UTC
I can't reproduce this on my setup, but I have opened a bug on the Darklaf project: https://github.com/weisJ/darklaf/issues/275

@reporter, can you reproduce the bug with a test plan, that uses no third party plugin?
Comment 5 chazhongbao 2021-09-17 23:27:11 UTC
I can't, but I know what's going on, this bug can be closed.
Comment 6 Felix Schumacher 2021-09-18 11:00:28 UTC
commit 1e69fefa0f250a7a149843d5e7074b7909010971
Author: Felix Schumacher <felix.schumacher@internetallee.de>
AuthorDate: Sat Sep 18 11:09:45 2021 +0200

    Update Darklaf to 2.7.3
    
    The update of Darklaf to 2.7.2 came with a regression regarding tooltips
    on linux and a NPE when playing an animation on JTrees.
    
    https://github.com/weisJ/darklaf/issues/274
    https://github.com/weisJ/darklaf/issues/275
    Bugzilla Id: 65579
---
 gradle.properties                           |  2 +-
 src/dist/src/dist/expected_release_jars.csv | 16 ++++++++--------
 xdocs/changes.xml                           |  2 +-
 3 files changed, 10 insertions(+), 10 deletions(-)