Bug 65636 - HTTP header empty when using ssl
Summary: HTTP header empty when using ssl
Status: RESOLVED DUPLICATE of bug 63192
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_ratelimit (show other bugs)
Version: 2.4.37
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-15 16:20 UTC by Marcin Wilk
Modified: 2021-10-15 17:28 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Wilk 2021-10-15 16:20:29 UTC
Hello.
I'm using httpd at CentOS 8 stable.
# uname -a
Linux myhost 4.18.0-305.19.1.el8_4.x86_64 #1 SMP Wed Sep 15 15:39:39 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
# httpd -v
Server version: Apache/2.4.37 (centos)
Server built:   May 20 2021 04:33:06

I'm hosting some files for some Linux distro, and they use script that check if the server is working correctly (it's just curl test). He let me know that my sever do not send header back. I've checked that and saw this:

$ curl -ILv https://siteaddres.com/files/someosfile.iso
* About to connect() to siteaddres.com port 443 (#0)
*   Trying 125.136.127.125...
* Connected to siteaddres.com (xxx) port 443 (#0)
* Initializing NSS with certpath: sql:/etc/pki/nssdb
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* SSL connection using TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
* Server certificate:
*       subject: CN=xxx
*       start date: Aug 16 00:10:55 2021 GMT
*       expire date: Nov 14 00:10:53 2021 GMT
*       common name: xxx
*       issuer: CN=R3,O=Let's Encrypt,C=US
> HEAD https://siteaddres.com/files/someosfile.iso HTTP/1.1
> User-Agent: curl/7.29.0
> Host: xxx
> Accept: */*
>
* Empty reply from server
* Connection #0 to host xxx left intact
curl: (52) Empty reply from server

When i disable mod_ratelimit config, it is working fine. When i use http instead of https with module enable it is also working fine.

I would be happy to trace it better but have no idea how.

Also i believe someone got same problem (on different Linux/Apache versions):
https://www.mail-archive.com/debian-apache@lists.debian.org/msg17576.html
Comment 1 Ruediger Pluem 2021-10-15 17:28:07 UTC

*** This bug has been marked as a duplicate of bug 63192 ***