Bug 65637 - Error starting child: Caused by: java.lang.StringIndexOutOfBoundsException
Summary: Error starting child: Caused by: java.lang.StringIndexOutOfBoundsException
Status: RESOLVED DUPLICATE of bug 65433
Alias: None
Product: Tomcat 8
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 8.5.69
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-15 17:35 UTC by Konstantin Ryadov
Modified: 2021-10-18 16:54 UTC (History)
0 users



Attachments
Tomcat log with java.lang.StringIndexOutOfBoundsException (5.92 KB, text/plain)
2021-10-15 17:36 UTC, Konstantin Ryadov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Ryadov 2021-10-15 17:35:31 UTC
Directory symlink inside webapp/<app_name>/WEB-INF directory leads to java.lang.StringIndexOutOfBoundsException - see attached tomcat_0.log

The application do not start.

Apache Tomcat/8.5.69            
Jun 30 2021 18:00:00 UTC        
8.5.69.0                        
Linux                           
3.10.0-1160.25.1.el7.x86_64     
amd64                           
/usr/java/jdk1.8.0_212-amd64/jre
1.8.0_212-b10                   
Oracle Corporation
Comment 1 Konstantin Ryadov 2021-10-15 17:36:01 UTC
Created attachment 38071 [details]
Tomcat log with java.lang.StringIndexOutOfBoundsException
Comment 2 Christopher Schultz 2021-10-18 16:54:33 UTC
Please upgrade Tomcat for the fix.

*** This bug has been marked as a duplicate of bug 65433 ***