Bug 65713 - Valid message-id can create broken link
Summary: Valid message-id can create broken link
Status: NEW
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_mbox (show other bugs)
Version: 2.4.39
Hardware: PC Mac OS X 10.1
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-29 17:10 UTC by Sebb
Modified: 2021-12-05 00:32 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebb 2021-11-29 17:10:16 UTC
I created a test message with what I understand to be a valid Message-ID, viz:

Message-ID: <1638203691.!#$%20&'*+-/=?^_`|{}~`@whimsy-vm6.apache.org>

The thread link [1] works fine, but the view raw message link [2] fails.

The message source can be seen in lists.a.o at [3]

[1] http://mail-archives.apache.org/mod_mbox/ponymail-dev/202111.mbox/%3c1638203691.!%23$%2520%26'*+-/=%3f%5e_%60%7c%7b%7d~%60@whimsy-vm6.apache.org%3e

[2]http://mail-archives.apache.org/mod_mbox/ponymail-dev/202111.mbox/raw/%3c1638203691.!%23$%2520%26'*+-/=%3f%5e_%60%7c%7b%7d~%60@whimsy-vm6.apache.org%3e

[3] https://lists.apache.org/api/source.lua?id=mz86ckwy7kg8vz8o47kn4pg55cjq5rhm
Comment 1 Sebb 2021-12-02 17:57:51 UTC
Another failure:

http://mail-archives.apache.org/mod_mbox/ponymail-dev/202112.mbox/%3c1638466811.!%23$%25%26'*+-/=%3f%5e_%7c%7b%7d~%60%22***%22@whimsy-vm6.apache.org%3e

I removed the 20 after the % in case it was being interpreted as space, but that has not helped.
Comment 3 Sebb 2021-12-05 00:32:09 UTC
Another valid MID for which the raw link does not work:

http://mail-archives.apache.org/mod_mbox/openoffice-dev/201208.mbox/%3cbug-120257-0-6QfGi87VgA@https.issues.apache.org/ooo/%3e

In this case I suspect the problem may be caused by the '/' in the domain part.