Bug 66289 - JSP page with relative path is not found, resulting in Jasper exception
Summary: JSP page with relative path is not found, resulting in Jasper exception
Status: RESOLVED DUPLICATE of bug 66277
Alias: None
Product: Tomcat 9
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 9.0.67
Hardware: PC All
: P2 normal (vote)
Target Milestone: -----
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-30 17:00 UTC by Sergey
Modified: 2022-09-30 17:08 UTC (History)
0 users



Attachments
Jasper Exception (6.66 KB, text/plain)
2022-09-30 17:04 UTC, Sergey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey 2022-09-30 17:00:54 UTC
The application is not deployed into webapps folder. Instead docBase property is specified in catalina/localhost/root.xml file.
The application has 2 pages:
- \parent.jsp
- \framework\child.jspf

The parent references child page in it's code:
 <%@ include file="framework/child.jspf"%>

The tomcat 9.0.67 throws HTTP error 500 because it can't find child.jspf.
however, if the syntax is changed to
 <%@ include file="/framework/child.jspf"%>
then Tomcat 9.0.67 is ok.

Tomcat 9.0.65 is ok with relative path
Comment 1 Sergey 2022-09-30 17:04:33 UTC
Created attachment 38398 [details]
Jasper Exception
Comment 2 Mark Thomas 2022-09-30 17:08:17 UTC

*** This bug has been marked as a duplicate of bug 66277 ***