Bug 66348 - new jars in lib
Summary: new jars in lib
Status: RESOLVED FIXED
Alias: None
Product: Tomcat 10
Classification: Unclassified
Component: Documentation (show other bugs)
Version: 10.1.1
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ------
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
: 66351 66353 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-11-15 15:38 UTC by elatllat
Modified: 2022-11-21 15:02 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description elatllat 2022-11-15 15:38:42 UTC
10.1.2 changed the jakartaee-migration-*-shaded.jar from optional to required.
Regardless of if that is a bug, the documentation is missing that jar in the lib list; 

https://tomcat.apache.org/tomcat-10.1-doc/class-loader-howto.html

on inspection 3 other required jars are also missing.
Please add the 4 JARs missing from the class-loader documentation; 

    > jakartaee-migration-*-shaded.jar -- required as of 10.1.2 
    > jaspic-api.jar
    > tomcat-jni.jar
    > tomcat-util-scan.jar
Comment 1 elatllat 2022-11-15 16:29:19 UTC
In addition to tomcat-i18n-*.jar , the following should also be marked optional:

    < catalina-ant.jar
    < catalina-ha.jar
    < catalina-ssi.jar
    < catalina-storeconfig.jar
    < catalina-tribes.jar
    < ecj-*.jar
    < el-api.jar
    < jasper-el.jar
    < jasper.jar
    < tomcat-dbcp.jar
    < tomcat-jdbc.jar
Comment 2 Mark Thomas 2022-11-15 16:58:32 UTC
(In reply to elatllat from comment #0)
> 10.1.2 changed the jakartaee-migration-*-shaded.jar from optional to
> required.

That is a bug that has already been fixed for 10.1.3 onwards.
Comment 3 elatllat 2022-11-15 17:16:30 UTC
Thanks for the information, is there a due date for 10.1.3?

Link to commit with fix:
https://github.com/apache/tomcat/commit/55f41d78c778a82e315b9980b56ff50e89e3af57


> Regardless
there are 4 JARs missing from the doc,

and at least 11 that should be marked optional (I'm not sure about the web socket JARs).
Comment 4 Han Li 2022-11-16 13:39:34 UTC
*** Bug 66351 has been marked as a duplicate of this bug. ***
Comment 5 Mark Thomas 2022-11-17 17:03:18 UTC
*** Bug 66353 has been marked as a duplicate of this bug. ***
Comment 6 Mark Thomas 2022-11-21 13:48:32 UTC
Fixed in:
- 10.1.x for 10.1.3 onwards
-  9.0.x for  9.0.70 onwards
-  8.5.x for  8.5.85 onwards
Comment 7 elatllat 2022-11-21 15:02:38 UTC
Thanks Mark,

Link to commit with fix:
https://github.com/apache/tomcat/commit/afed131394261b4ac5bd324811bc6bdd9de4bd3f