Bug 68928 - Apache httpd not starting with mod_jk 1.2.49 after upgrade to SLES 15 SP5
Summary: Apache httpd not starting with mod_jk 1.2.49 after upgrade to SLES 15 SP5
Status: RESOLVED DUPLICATE of bug 66005
Alias: None
Product: Tomcat Connectors
Classification: Unclassified
Component: mod_jk (show other bugs)
Version: 1.2.49
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2024-04-22 11:21 UTC by SimEon
Modified: 2024-04-22 13:56 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SimEon 2024-04-22 11:21:39 UTC
Good morning!

We have been upgrading our system from SLES 12 to SLES 15 SP5.

We are running a self-compiled Apache httpd with mod_jk on multiple similar systems. They are running fine on SLES 12, but stop working on SLES 15 SP5. We tested with the following two sets of versions, but got the same results today:

1)
httpd_version: httpd-2.4.58
jk_version: tomcat-connectors-1.2.49-src
openssl_version: openssl-3.0.12
pcre_version: pcre-8.45
apr_version: apr-1.7.4
apr_util_version: apr-util-1.6.3

2)
httpd_version: httpd-2.4.59
jk_version: tomcat-connectors-1.2.49-src
openssl_version: openssl-3.3.0
pcre_version: pcre-8.45
apr_version: apr-1.7.4
apr_util_version: apr-util-1.6.3


The error was a not starting httpd with the module mod_jk.so included within the configuration. Without the mod_jk.so in the config the httpd process was running fine.

Error messages:

1. In syslog it shows the process dump:
2024-04-22T06:20:54.594579+00:00  systemd[1]: Starting The Apache HTTP Server...
2024-04-22T06:20:54.656987+00:00  systemd[1]: Started The Apache HTTP Server.
2024-04-22T06:20:54.683137+00:00  systemd[1]: Started Process Core Dump (PID 14707/UID 0).
2024-04-22T06:20:54.958281+00:00  systemd-coredump[14708]: Process 14706 (httpd) of user 0 dumped core.#012#012Found module linux-vdso.so.1 with build-id: d74f0fa9e6060ef50f04c54743fb715c80644efa#012Found module mod_env.so with build-id: b09767ea8787f9edb7dd59e6d2bf5bef62e54a16#012Found module mod_expires.so with build-id: f92c0b312e0af0ebef8734ec326538c22879d90f#012Found module mod_cache_disk.so with build-id: cd6b448361f9583b797a669aed525a045ab291f9#012Found module mod_cache.so with build-id: 9a7aa6f344900598d28b3ec3e67711fd2825ae02#012Found module mod_deflate.so with build-id: 97ce87386abda3446a8a54ce590ecfd19e37ddbd#012Found module mod_filter.so with build-id: 559eb5331e63f1b433a5597fa304062851ac4a81#012Found module mod_setenvif.so with build-id: 3e293f1905ebb3e1f962bb0a5303c65bc0139834#012Found module mod_lbmethod_bytraffic.so with build-id: be82ad83f17b7c9cdff8d92d98127b34fae3a16e#012Found module mod_rewrite.so with build-id: 41009232c80c69da2eb3d68d2b5ddb0a9602ee6c#012Found module mod_proxy_http.so with build-id: 3bfcade3b891801786ec25269d019c1e1e80e16d#012Found module mod_lbmethod_byrequests.so with build-id: 3ff4f5930fa07c14021b1f82532db2a0d7badd56#012Found module mod_slotmem_shm.so with build-id: 2e02511ba76733ebb4993c1d110e76ab6028c688#012Found module mod_proxy_balancer.so with build-id: ec73ee99138cc5ff48f3b2434f9a2b5fc0df2fac#012Found module mod_proxy_connect.so with build-id: 3b12468ddb85b5a5972b391bc03df064484dd674#012Found module mod_proxy.so with build-id: 8b9716c849a962972180d521d24be354cf734f34#012Found module mod_headers.so with build-id: 12fa2d10cbe963dfb506a959ce064be39650c9b9#012Found module mod_unique_id.so with build-id: 2b03b6fa0464c9b1869e86c2404dadd21416a40c#012Found module mod_status.so with build-id: deaf7ff59eac61c5db3d64a028d4d73536147536#012Found module mod_alias.so with build-id: da6dec92b937af8a41190c33c14a22e04ce37314#012Found module mod_unixd.so with build-id: 47a3b68b9b827a14189dd7a198dae8bcba92d3d3#012Found module mod_log_config.so with build-id: 02a955eba9349826e308ec602e0ab11c8d8fa73d#012Found module mod_mime.so with build-id: 672a4dfa2b17474a86a964972f7e3497545ac8b9#012Found module mod_reqtimeout.so with build-id: f148e20565439ab1bc26158ef12a1673d95e0ee5#012Found module mod_socache_shmcb.so with build-id: b6f530e391a1feae47c5eeaf4ab840412e7e54c4#012Found module mod_authz_core.so with build-id: 8ffb3e83446fe2ce293a3b7bf9ce2e8c2be4a173#012Found module mod_authz_host.so with build-id: 17d63013b75c5cc8194c505cba900fe0c4c5c507#012Found module libnss_dns.so.2 with build-id: ef2fd4ef2dc5c4f31c311c8e2f120405c2850e5d#012Found module libnss_files.so.2 with build-id: 2c0a191e2c931e65d5f1945052e226470aa54a26#012Found module libjitterentropy.so.3 with build-id: 6cd5111426fb5f10ef2d5fb9109ef901dd6a67f5#012Found module libselinux.so.1 with build-id: 58d24c02a015417be0c526fa565cfb868164ab7a#012Found module libcrypto.so.1.1 with build-id: b61a8d70989fdd00494c15631ad05356193b8234#012Found module libresolv.so.2 with build-id: 86b7fb29524c820668a22605592a9030e80a2907#012Found module libkeyutils.so.1 with build-id: 03f844991b5ec4ba1daa95ae19e06faaeb59be31#012Found module libkrb5support.so.0 with build-id: 0dbea5394276f0fd34c8e605ec8f9ae088867f65#012Found module libcom_err.so.2 with build-id: 2875e21b1e71237a94d63d41390320bbcc0171e6#012Found module libk5crypto.so.3 with build-id: 60ea4456f31c7ec6b99bfef03cb2326e65b368c9#012Found module libkrb5.so.3 with build-id: aa241801b9f1f7619edd2c7328f3a297f0121559#012Found module libgssapi_krb5.so.2 with build-id: 19cb7adbefeaf37f73fede40a1d1afa4224d6e9c#012Found module libtirpc.so.3 with build-id: 3c9ff7d5fca0caa559d1a3df74200c2e345c8486#012Found module libnsl.so.2 with build-id: 0ffb87fedcfdc4c527a879da8302d9d595f10f5b#012Found module libnss_nis.so.2 with build-id: a267eac50bf201797d52fd8495b78417b8ea9ccc#012Found module libnss_compat.so.2 with build-id: f410ed0f72bace6adda6649ef8aa65ee64909806#012Found module libz.so.1 with build-id: 0bd1b117f07eb8157bb2931e94d966fbb352f652#012Found module mod_jk.so with build-id: 9f19bdd5a6479f353232ec777f8f86476b562da9#012Found module ld-linux-x86-64.so.2 with build-id: 57843fcc97e581584526c2010667fcf0e0583294#012Found module libc.so.6 with build-id: 4b30629cfedbec041523c3e9abf5e3576277533c#012Found module libdl.so.2 with build-id: ddb3608328ac8fab4253f5aad6a36a1ea77ce68d#012Found module libpthread.so.0 with build-id: bd2486d198706e4c0c94c5c580635842cdfc5c44#012Found module libcrypt.so.1 with build-id: 57930159d50d6edc1adffca45f268126b3724ebf#012Found module librt.so.1 with build-id: 6e7654eae0cccab929dc5683e2acdfec92943720#012Found module libapr-1.so.0 with build-id: 3293f352b04913da6d31f33b6a0e2ba03da3b7fc#012Found module libexpat.so.1 with build-id: 335cb65db76c2fcfe35c0f681636e3f35017f03f#012Found module libaprutil-1.so.0 with build-id: 2ebfd1ebae367e6e47ea4495d8ac36e611c3a94c#012Found module libpcre.so.1 with build-id: 02bcb3fc798a1342677b6c8e3a8d268832f44072#012Found module libcrypto.so.3 with build-id: bbb1688382c5e8b7d2c2bf35be3f7110114c6fd7#012Found module libssl.so.3 with build-id: 226180b038297d0e18599c62a42f88278596ccbe#012Found module httpd with build-id: dde67faa193221b4a507f6561d54e9658cdb3ce1#012Stack trace of thread 14706:#012#0  0x00007fad5876f0b0 run_cleanups (libapr-1.so.0 + 0x230b0)#012#1  0x00007fad581c64d4 jk_resolve (mod_jk.so + 0x224d4)#012#2  0x00007fad581e9ab6 ajp_validate (mod_jk.so + 0x45ab6)#012#3  0x00007fad581cfbb9 validate (mod_jk.so + 0x2bbb9)#012#4  0x00007fad581ce7e0 wc_create_worker (mod_jk.so + 0x2a7e0)#012#5  0x00007fad581d1ab9 validate (mod_jk.so + 0x2dab9)#012#6  0x00007fad581ce7e0 wc_create_worker (mod_jk.so + 0x2a7e0)#012#7  0x00007fad581cef8b build_worker_map (mod_jk.so + 0x2af8b)#012#8  0x00007fad581c242d init_jk (mod_jk.so + 0x1e42d)#012#9  0x0000000000464be9 ap_run_post_config (httpd + 0x64be9)#012#10 0x000000000043e0cc main (httpd + 0x3e0cc)#012#11 0x00007fad5823e24d __libc_start_main (libc.so.6 + 0x3524d)#012#12 0x000000000043e289 _start (httpd + 0x3e289)
2024-04-22T06:20:54.961503+00:00  systemd[1]: systemd-coredump@4-14707-0.service: Deactivated successfully.
2024-04-22T06:20:54.963974+00:00  systemd[1]: apache2.service: Main process exited, code=dumped, status=11/SEGV
2024-04-22T06:20:54.964219+00:00  systemd[1]: apache2.service: Failed with result 'core-dump'.


Build commands of httpd:

./configure --prefix=/opt/httpd --with-pcre=/opt/pcre/bin/pcre-config --with-included-apr --enable-ssl --enable-deflate --with-ssl=/opt/openssl --enable-ssl-staticlib-deps --enable-mods-static=ssl
make
make install


Build commands of mod_jk:
./configure --with-apxs=/opt/httpd/bin/apxs
make



Since we have upgraded to SLES 15 SP5 we would suspect a programmatic error within mod_jk or some kind of a compatibility error.

Please let us know in case any more details are required.

Kind Regards,
SimEon
Comment 1 Rainer Jung 2024-04-22 12:45:32 UTC
Fix for 1.2.49 was incomplete due to a typo in the Makefile. See comment #33 in BZ 66005.

*** This bug has been marked as a duplicate of bug 66005 ***
Comment 2 SimEon 2024-04-22 13:56:18 UTC
(In reply to Rainer Jung from comment #1)
> Fix for 1.2.49 was incomplete due to a typo in the Makefile. See comment #33
> in BZ 66005.
> 
> *** This bug has been marked as a duplicate of bug 66005 ***


Thank you very much. 

We got it running with re-building mod_jk again and beforehand renaming "-export-symbols-regexp" to "-export-symbols-regex" in apache-2.0/Makefile.in as mentioned in BZ 66005.


Danke & Gruss,
Simeon