Bug 69027 - Incorrect reference to Digest::SHA1
Summary: Incorrect reference to Digest::SHA1
Status: NEW
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: support (show other bugs)
Version: 2.5-HEAD
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2024-05-19 21:30 UTC by tlhackque
Modified: 2024-05-19 21:30 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tlhackque 2024-05-19 21:30:14 UTC
https://svn.apache.org/viewvc/httpd/httpd/trunk/support/dbmmanage.in?view=markup&pathrev=1884207#l54

dbmmanage SHA1 passwords require the interface or the module Digest::SHA1
55	available from CPAN:
56	
57	    http://www.cpan.org/modules/by-module/Digest/Digest-MD5-2.12.tar.gz

Obviously, a copy and paste error.  MD5 isn't SHA1.

The correct link is:

https://metacpan.org/dist/Digest::SHA1

However, Digest::SHA is a superset and better maintained.

(Note that the other references to cpan.org redirect to metacpan.org and probably should also be updated.)