Bug 69140 - REGRESSION in change from Base64 from apache commons to java class
Summary: REGRESSION in change from Base64 from apache commons to java class
Status: RESOLVED DUPLICATE of bug 69066
Alias: None
Product: Tomcat 10
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 10.1.24
Hardware: PC All
: P2 normal (vote)
Target Milestone: ------
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2024-06-18 22:59 UTC by Mircea Butmalai
Modified: 2024-06-19 22:26 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mircea Butmalai 2024-06-18 22:59:55 UTC
Somewere between changes from 10.1.20 to 10.1.24 it was introduced a change in SpnegoAuthenticator that creates a big problem in Windows Integrated Authentication.
The change is consisting in the fact that was deprected (and removed) the class
import org.apache.tomcat.util.codec.binary.Base64;

and replaced with class

import java.util.Base64;

The rest of changes are derived from this fact.

The problem is that when Windows Integrated Authentication happens from Windows 10 station Tomcat reports exception with some unrecognised character exception.

It is very clear that this change is implemented more permissive in decoding / encoding process with respect with whitespace characters and coding of those characters in URL.
Comment 1 Mircea Butmalai 2024-06-19 02:17:31 UTC
I will come again with details about exception thrown by Tomcat when Windows Integrated Authentication happens ...
Comment 2 Mircea Butmalai 2024-06-19 02:18:58 UTC
For now it is clear for me that all versions of Tomcat (9.0.x, 10.1.x and 11) must have this problem.
Comment 3 Mircea Butmalai 2024-06-19 02:18:59 UTC
For now it is clear for me that all versions of Tomcat (9.0.x, 10.1.x and 11) must have this problem.
Comment 4 Remy Maucherat 2024-06-19 07:48:34 UTC
No details here, but most likely a duplicate.

*** This bug has been marked as a duplicate of bug 69066 ***
Comment 5 Mircea Butmalai 2024-06-19 22:26:03 UTC
Yes this bug is exactly the same bug as the one marked as duplicate