Bug 7288 - Bug in negative character ranges
Summary: Bug in negative character ranges
Status: CLOSED FIXED
Alias: None
Product: Regexp
Classification: Unclassified
Component: Other (show other bugs)
Version: unspecified
Hardware: All other
: P3 major (vote)
Target Milestone: ---
Assignee: Jakarta Notifications Mailing List
URL:
Keywords:
: 11689 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-03-20 16:12 UTC by Sascha Weinreuter
Modified: 2004-11-16 19:05 UTC (History)
1 user (show)



Attachments
suggested fix and updated test cases (211 bytes, patch)
2002-03-20 16:13 UTC, Sascha Weinreuter
Details | Diff
suggested fix and updated test cases [2] (864 bytes, patch)
2002-03-20 16:16 UTC, Sascha Weinreuter
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sascha Weinreuter 2002-03-20 16:12:19 UTC
Negative character ranges like "[^ac]+" match any character except a, c _AND_ b.

This seems to be caused by an improper range check in RECompiler.RERange.remove
().
Comment 1 Sascha Weinreuter 2002-03-20 16:13:25 UTC
Created attachment 1394 [details]
suggested fix and updated test cases
Comment 2 Sascha Weinreuter 2002-03-20 16:16:24 UTC
Created attachment 1395 [details]
suggested fix and updated test cases [2]
Comment 3 Jon Stevens 2002-12-13 18:27:31 UTC
patches applied and tests made.
Comment 4 Jon Stevens 2002-12-13 18:27:46 UTC
closed.
Comment 5 Jon Stevens 2002-12-13 18:29:00 UTC
*** Bug 11689 has been marked as a duplicate of this bug. ***