Bug 7441 - RFC 2616 - Apache incorrectly expects a non-empty Host header
Summary: RFC 2616 - Apache incorrectly expects a non-empty Host header
Status: CLOSED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Core (show other bugs)
Version: 2.0-HEAD
Hardware: Other Linux
: P3 critical (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
: 8422 8604 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-03-25 11:41 UTC by Dinesh Patel
Modified: 2004-11-16 19:05 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dinesh Patel 2002-03-25 11:41:02 UTC
Running Apache 2.0.28 server on RedHat Linux
Set up machine, OS and Apache for IPv6 networking
Tried to download HTTP content by specifying the IPv6 numerical IP address
The Apache server is not fully HTTP 1.1 compliant.  
The server incorrectly expects a non-empty Host header even when the server is 
specified by a numeric IP address e.g. 10.158.7.52. 
The host header should be empty when the server IP address is specified using a 
numerical address.
Server incorrectly returns and 400 http server code.


rfc2616 - Hypertext Transfer Protocol -- HTTP/1.1
Section 14.23 Host

IPv6 browsers will not work on Apache if this is not fixed.
Comment 1 Joshua Slive 2002-03-25 15:53:45 UTC
Confirmed.  And this is a regression from 1.3, which handles this correctly.

However, I don't think it has anything to do with IPv6.  The same issue is
present with ordinary old IPv4 addresses.

Although this should be fixed, I'm not sure why this is causing you a problem.
All the browsers that I've seen send the IP address in the Host: header when
they don't have a name, and this works fine.
Comment 2 Justin Erenkrantz 2002-04-15 02:59:31 UTC
This should be resolved in revision 1.73 of server/vhost.c.

This will be included in the next release of Apache httpd-2.0.

Thanks for using Apache!
Comment 3 Justin Erenkrantz 2002-04-23 17:25:47 UTC
*** Bug 8422 has been marked as a duplicate of this bug. ***
Comment 4 Cliff Woolley 2002-04-29 03:43:35 UTC
*** Bug 8604 has been marked as a duplicate of this bug. ***