Bug 7818 - Stale config.guess in tarball
Summary: Stale config.guess in tarball
Status: CLOSED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Build (show other bugs)
Version: 2.0.35
Hardware: Macintosh All
: P3 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
: 7970 8405 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-04-07 17:54 UTC by Sander Temme
Modified: 2005-03-20 17:06 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sander Temme 2002-04-07 17:54:59 UTC
While configuring apr-util:

checking for Expat in /usr... no
checking for Expat in /usr/local... no
checking for Expat in xml/expat-cvs... no
checking for Expat in xml/expat... yes
updating cache /Users/sctemme/projects/httpd-2.0.35/./config.cache
configuring package in xml/expat now
loading cache /Users/sctemme/projects/httpd-2.0.35/./config.cache
checking host system type... configure: error: can not guess host type; you 
must specify one
configure failed for xml/expat
configure failed for srclib/apr-util
[monalisa:~/projects/httpd-2.0.35] sctemme% 

The workaround is to find config.guess and config.sub in /usr/libexec on 
the local machine and copy them over the offending ones. 

We've been here before. The expat in CVS does not exhibit this problem. 
The 2.0.32 tarball did not exhibit this problem. I don't know exactly what is 
happening... maybe the action of rolling the tarball sucks in an expat from 
outside CVS? I browsed the httpd_roll_release script in CVS and saw 
nothing but a plain old checkout.
Comment 1 Justin Erenkrantz 2002-04-15 06:34:00 UTC
*** Bug 7970 has been marked as a duplicate of this bug. ***
Comment 2 Matthew Boehm 2002-04-15 07:54:53 UTC
I copied config.guess and config.sub from my /usr/libexec/ to the following 
locations:
  /root/httpd-2.0.35/
  /root/httpd-2.0.35/srclib/apr-util
  /root/httpd-2.0.35/srclib/apr-util/xml/expat

Ran main configure, got same error as Sander. Ran apr-util configure, 
same error. Ran expat configure, same error.

Ran expat configure as so: ./configure --host=powerpc-apple-darwin5.3 
and got following:
loading cache ./config.cache
checking host system type... Invalid configuration `powerpc-apple-
darwin5.3': system `darwin5.3' not recognized

checking target system type... Invalid configuration `powerpc-apple-
darwin5.3': system `darwin5.3' not recognized

checking build system type... Invalid configuration `powerpc-apple-
darwin5.3': system `darwin5.3' not recognized

checking for ranlib... ranlib
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... no
checking for BSD-compatible nm... /usr/bin/nm -p
checking whether ln -s works... yes
updating cache ./config.cache
loading cache ./config.cache within ltconfig
ltconfig: you must specify a host type if you use `--no-verify'
Try `ltconfig --help' for more information.
configure: error: libtool configure failed

Re-Ran with following: ./configure --host=powerpc-apple-bsd
and everything configured fine.

Matthew
Comment 3 Justin Erenkrantz 2002-04-16 08:52:26 UTC
I have merged in the latest config.guess/config.sub from GNU.

I also explicitly added config.guess/config.sub for expat.  This should explain
why our bundled expat is acting weird - it was using the config.guess from
icarus rather than a recent one.

For more information, please see the commit log:
http://cvs.apache.org/viewcvs.cgi/httpd-2.0/CHANGES?rev=1.709&content-type=text/vnd.viewcvs-markup

Please try a nightly build to see if your problem goes away.

I will close this PR for now.  If the problem remains with the next release (or
a nightly), you may reopen it.

Thanks for using Apache!
Comment 4 Justin Erenkrantz 2002-04-23 17:22:11 UTC
*** Bug 8405 has been marked as a duplicate of this bug. ***
Comment 5 Sander Temme 2002-05-12 17:35:47 UTC
Verified with Apache 2.0.36 release. Closing... I assume as reporter it's 
my prerogative/task to close.