Bug 7841 - httpd.pid file placement in httpd-std.conf
httpd.pid file placement in httpd-std.conf
Status: CLOSED FIXED
Product: Apache httpd-2
Classification: Unclassified
Component: All
2.0.35
Other Linux
: P3 minor (vote)
: ---
Assigned To: Apache HTTPD Bugs Mailing List
:
: 7798 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2002-04-08 14:49 UTC by Andreas Hasenack
Modified: 2004-11-16 19:05 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Hasenack 2002-04-08 14:49:53 UTC
Should the PID file really be placed in the logdir?

--- httpd-2.0.35/docs/conf/httpd-std.conf.in.confvars   2002-04-04
06:15:43.000000000 -0300
+++ httpd-2.0.35/docs/conf/httpd-std.conf.in    2002-04-07 17:54:11.000000000 -0300
@@ -78,7 +78,7 @@
 # identification number when it starts.
 #
 <IfModule !mpm_netware.c>
-PidFile @rel_logfiledir@/httpd.pid
+PidFile @rel_runtimedir@/httpd.pid
 </IfModule>
 
 #
Comment 1 Justin Erenkrantz 2002-04-12 01:10:12 UTC
This has been committed to the Apache httpd-2.0 CVS repository and will
be included in the next release of Apache httpd-2.0.

docs/conf/httpd-std.conf.in revision 1.2 has this change.

Thanks for using Apache!
Comment 2 Cliff Woolley 2002-04-21 21:28:11 UTC
*** Bug 7798 has been marked as a duplicate of this bug. ***