Bug 7970 - Configure script does not pass arguments.
Summary: Configure script does not pass arguments.
Status: CLOSED DUPLICATE of bug 7818
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Build (show other bugs)
Version: 2.0.35
Hardware: Macintosh All
: P3 blocker (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-04-11 16:03 UTC by Matthew Boehm
Modified: 2005-03-20 17:06 UTC (History)
0 users



Attachments
Patch for configure (896 bytes, patch)
2002-04-14 18:41 UTC, Matthew Boehm
Details | Diff
Configure output on fresh tarball (12.84 KB, text/plain)
2002-04-15 02:37 UTC, Matthew Boehm
Details
Configure output of different commands on fresh tarball (25.28 KB, text/plain)
2002-04-15 02:43 UTC, Matthew Boehm
Details
New configure output for cache copying (13.64 KB, text/plain)
2002-04-15 02:55 UTC, Matthew Boehm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Boehm 2002-04-11 16:03:07 UTC
loading cache /root/httpd-2.0.35/./config.cache
checking host system type... configure: error: can not guess host type; you 
must specify one
configure failed for xml/expat
configure failed for srclib/apr-util

Even when I specify: 
--build=powerpc-apple-bsd --host=powerpc-apple-bsd
to the main configure script, it does not pass these along to the apr-util 
configure script.

I created a workaround by editing line 1947 of the main configure script. 
All I did was add the two switches to that line so that when the main 
configure script call the apr-util configure, the values got passed.

Once this was done, the main configure worked fine. Apace 2.0.35 
compiled fine on my 10.1.2 and runs great.

Matthew
Comment 1 Justin Erenkrantz 2002-04-12 02:01:01 UTC
It would be very helpful if you supplied a unified patch that you applied to fix
this problem.

FWIW, configure works fine here on OS 10.1.3, so I'm not sure why you are even
attemping to override this information.  Is there a problem with the
config.guess information?

jerenk@localhost% ./config.guess
powerpc-apple-darwin5.3
Comment 2 Matthew Boehm 2002-04-12 08:07:42 UTC
OK. I was running 10.1.2. I just updated to 10.1.3 (Build 5Q45) and 
downloaded a fresh httpd-2.0.35.tar.gz from Apache.org.

My config was:
./configure --enable-usertrack --enable-unique-id --enable-ssl --with-ssl=/
usr/local/include/ --enable-cgi --enable-cgid --enable-vhost-alias --
enable-speling -enable-rewrite  --enable-so

Configure runs and reaches this error:

Configuring Apache Portable Runtime Utility library...
configuring package in srclib/apr-util now
loading cache /var/root/httpd-2.0.35/./config.cache
checking for APR... yes
...
updating cache /var/root/httpd-2.0.35/./config.cache
configuring package in xml/expat now
loading cache /var/root/httpd-2.0.35/./config.cache
checking host system type... configure: error: can not guess host type; you 
must specify one
configure failed for xml/expat
configure failed for srclib/apr-util

However, the main configure script guessed it perfectly:
creating cache ./config.cache
checking for chosen layout... Apache
checking host system type... powerpc-apple-darwin5.3
checking target system type... powerpc-apple-darwin5.3
checking build system type... powerpc-apple-darwin5.3

The main config script is not passing these variables to the apr-util 
configure script. The only way I have found around it is by editing the main 
config script as stated in my previous bug report.

I've never made a patch file before. Do you have instructions?

matthew
Comment 3 Jeff Trawick 2002-04-12 14:01:33 UTC
This will build a patch:

$ diff -u oldfile newfile >patch
Comment 4 Matthew Boehm 2002-04-14 18:41:35 UTC
Created attachment 1563 [details]
Patch for configure
Comment 5 Matthew Boehm 2002-04-14 18:44:04 UTC
I attached my patch for the main configure. Run the main configure and let 
it guess the host type. Mine guessed "powerpc-apple-darwin5.3" which I 
believe is correct. Now, when the main configure script passes the build 
and host variables to the apr-util configure script, it will complain that it 
doesn't know how to build for that host.

Now, go back to main configure and force
both build and host = powerpc-apple-bsd

Then it will all work fine.

Matthw
Comment 6 Justin Erenkrantz 2002-04-15 01:14:05 UTC
Can you please attach your config.log file?

Thanks!
Comment 7 Matthew Boehm 2002-04-15 02:37:47 UTC
Created attachment 1570 [details]
Configure output on fresh tarball
Comment 8 Matthew Boehm 2002-04-15 02:43:22 UTC
Created attachment 1571 [details]
Configure output of different commands on fresh tarball
Comment 9 Matthew Boehm 2002-04-15 02:46:20 UTC
Alright. I just did some different stuff.
1. I downloaded a fresh copy of httpd-2.0.35.tar.gz
2. Untared it.
3. Did ./configure with the commands listed at the top of
    attachment "04/15/02 02:37"
4. The output was saved to the attachment on #3.

5. Removed all files and re-untared to get fresh files.
6. Did ./configure with the commands listed at the top of
    attachment "04/15/02 02:43"
7. The output was saved to the attachment on #6.

I guess this means that the patch isn't needed anymore. But the fact 
remains that apr-util's configure has an issue with build and host 
variables.

Matthew
Comment 10 Justin Erenkrantz 2002-04-15 02:46:36 UTC
Thanks.

Can you please try copying the config.guess in srclib/apr/build/config.guess to
srclib/apr-util/xml/expat/conftools/config.guess?

These two files aren't the same, so it's possible that the expat config.guess
is out-of-date and doesn't recognize Darwin.  But, it works for me on my 10.3
box.  Odd.  It's worth a shot.
Comment 11 Matthew Boehm 2002-04-15 02:55:12 UTC
Created attachment 1572 [details]
New configure output for cache copying
Comment 12 Matthew Boehm 2002-04-15 02:56:46 UTC
OK. I copied the config.guess to where you told me. The output is listed 
as file "04/15/02 02:55" and I used the same arguments as listed at the 
top of the 2:37 attachemnent.

Matthew
Comment 13 Justin Erenkrantz 2002-04-15 06:33:59 UTC
This *is* a duplicate of Bug 7818.  Sander Temme has a proposed solution listed
there.  Can you try it and append comments to that bug?

Thanks!

*** This bug has been marked as a duplicate of 7818 ***