Bug 8037 - documentation of Script directive does not define arguments well enough
Summary: documentation of Script directive does not define arguments well enough
Status: CLOSED FIXED
Alias: None
Product: Apache httpd-1.3
Classification: Unclassified
Component: Documentation (show other bugs)
Version: 1.3.23
Hardware: All All
: P3 normal (vote)
Target Milestone: ---
Assignee: HTTP Server Documentation List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-04-12 21:02 UTC by bugapache
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugapache 2002-04-12 21:02:26 UTC
I've been fighting with trying to get PUT scripts working on my
server off and on for six months, searching the web for examples
and following them without success.  It turns out that the
problem was that I was using the file system path name for the
cgi argument of the 'script PUT' directive instead of the URL.
The script ran, but an error message was generated that said
that the full filesystem path name, with the location of the
PUT file appended, did not have permission for a PUT request.
Needless to say, this totally confused me and lead to six months
of a non functioning site.

Hmm.  Although I'm submitting this as a doc bug (script should
be explicit about what it is expecting for the 'cgi-script'
argument), the actual bug may more properly be a bug in the
error message that results from putting the wrong thing
for that argument...
Comment 1 Joshua Slive 2002-04-14 17:00:54 UTC
I have improved the documentation to tell people that cgi-script is a URL-path.
You are correct that this was not clear (although the example seems to make
it obvious).

As far as your problem with the error message, I'm not exactly sure what you
mean.  If you want that addressed, please file another report specifically
addressing that issue.

Thanks for using Apache.