Bug 8276 - NoClassDefFoundError: org/apache/taglibs/standard/tag/el/core/ExprTag
Summary: NoClassDefFoundError: org/apache/taglibs/standard/tag/el/core/ExprTag
Status: CLOSED WORKSFORME
Alias: None
Product: Taglibs
Classification: Unclassified
Component: Standard Taglib (show other bugs)
Version: unspecified
Hardware: All All
: P3 blocker (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-04-18 20:56 UTC by Hans Bergsten
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hans Bergsten 2002-04-18 20:56:02 UTC
This <c:out> (used to illustrate what happens for an invalid bean property)

  <c:out value="${pageContext.request.requestUri}" />

results in this exception root cause:

java.lang.NoClassDefFoundError: org/apache/taglibs/standard/tag/el/core/ExprTag
	at java.lang.Class.newInstance0(Native Method)
	at java.lang.Class.newInstance(Class.java:237)
	at org.apache.jasper.servlet.JspServlet$JspServletWrapper.load(JspServlet.java:139)
...

in the 4/18 build. Other <c:out>'s work fine. Maybe there's an old reference
to ExprTag (now called OutTag, I believe) in a class related to exception
handling?
Comment 1 Shawn Bayern 2002-04-18 20:59:11 UTC
Hans, this doesn't sound right; just to be sure, I checked for textual
dependencies on the class's name in JSTL.  Are you sure you're working from a
pristine environment, with no classes hanging around from a prior build and no
old files in Tomcat's workspace?
Comment 2 Hans Bergsten 2002-04-18 21:27:41 UTC
Ah, a servlet had been generated and compiled for this page with an earlier
version of JSTL, including references to the ExprTag instead of OutTag. Forcing
a recompile fixed it.

Sorry about that.