Bug 8371 - sql_rt:query with invalid maxRows attribute
Summary: sql_rt:query with invalid maxRows attribute
Status: RESOLVED INVALID
Alias: None
Product: Taglibs
Classification: Unclassified
Component: Standard Taglib (show other bugs)
Version: 1.0
Hardware: All All
: P3 major (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-04-22 17:07 UTC by Lance Andersen
Modified: 2004-11-16 19:05 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lance Andersen 2002-04-22 17:07:46 UTC
The following does not throw a JspException, instead a translation error occurs
due to a NumberFormatException

    <sql_rt:query var="resultSet2"  maxRows="invalid"
                    dataSource='<%=(DataSource) pageContext.getAttribute("jstlDS
", PageContext.APPLICATION_SCOPE) %>'  >
          <%=((Properties)pageContext.getAttribute("sqlProps",PageContext.APPLIC
ATION_SCOPE)).getProperty("Simple_Select_Query") %>
      </sql_rt:query>
Comment 1 Jan Luehe 2002-04-23 22:19:56 UTC
Not a bug. The JSTL spec does not say that invalid values may be reported only
at runtime (even if they could have been detected at translation time).