Bug 8376 - <fmt:setBundle> does not allow scope without var
Summary: <fmt:setBundle> does not allow scope without var
Status: RESOLVED INVALID
Alias: None
Product: Taglibs
Classification: Unclassified
Component: Standard Taglib (show other bugs)
Version: unspecified
Hardware: Other Windows XP
: P3 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-04-22 19:04 UTC by David Geary
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Geary 2002-04-22 19:04:18 UTC
<fmt:Bundle basename='app' scope='session'/> should store a resource bundle in 
the javax.servlet.jsp.jstl.fmt.localizationContext config setting for session 
scope. Instead, I get this validation error:

Validation error messages from tag library fmt
null: Illegal scope attribute without var in "fmt:setBundle" tag.

(From 20020422 build)
Comment 1 Jan Luehe 2002-04-22 19:28:21 UTC

*** This bug has been marked as a duplicate of 8225 ***
Comment 2 Jan Luehe 2002-04-23 16:22:40 UTC
Not a duplicate of 8225.
Comment 3 Jan Luehe 2002-04-23 16:32:52 UTC
Taglib directive of the page that triggered this issue was using a custom URI
("standard-fmt") instead of the "standard" URI ("http://java.sun.com/jstl/fmt")
that is specified in fmt.tld.
Because of this, the FMT TLV did not consider the page's tags as JSTL tags,
prompting it to flag a dangling-scope error where one was not expected.