Bug 8424 - IPV6 and IPV4 bind
Summary: IPV6 and IPV4 bind
Status: CLOSED DUPLICATE of bug 7492
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Core (show other bugs)
Version: 2.0.35
Hardware: All other
: P3 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-04-23 16:40 UTC by Jean-Edouard BABIN
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Edouard BABIN 2002-04-23 16:40:48 UTC
Hi,

I have tried Apache 2 on FreeBSD and NetBSD, on FreeBSD when i 
launch it, he bind on all ipv4 and ipv6 adresse.
but on NetBSD he only bind on IPv6, so i can't use it on IPv4 and IPv6 in 
the same time.
Comment 1 Jeff Trawick 2002-04-30 18:39:24 UTC
On NetBSD you'll need to add an additional listen statement like the one
shown below in order to accept IPv4 connections too:

  Listen 0.0.0.0:80

Comment 2 Jean-Edouard BABIN 2002-04-30 22:48:12 UTC
Thanks for this info, i just want to add that Listen [0::0]:80 is also required 
for the ipv6 binding, but i am wondering why he don't automatically bind 
on both ipv4 and ipv6
Comment 3 Jeff Trawick 2002-10-10 11:17:06 UTC

*** This bug has been marked as a duplicate of 7492 ***
Comment 4 Jeff Trawick 2002-10-10 12:08:48 UTC
Whoops, this is a duplicate of 7492 in the OLD bug database, not 7492 in
the current bugzilla database.

Use this link to find the old bug 7492:

http://bugs.apache.org/index.cgi/full/7492