Bug 8593 - FORMULAS -- Strange bug with Formulas
Summary: FORMULAS -- Strange bug with Formulas
Status: RESOLVED DUPLICATE of bug 8592
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 2.0-dev
Hardware: Other other
: P3 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-04-27 22:18 UTC by Andy Oliver
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Oliver 2002-04-27 22:18:43 UTC
In the event more than 3 rows contain formuls the following exception occurs:

There was 1 error:
1) testAddIntegers(org.apache.poi.hssf.usermodel.TestFormulas)
java.lang.ArrayIndexOutOfBoundsException
        at org.apache.poi.util.LittleEndian.putNumber(LittleEndian.java:536)
        at org.apache.poi.util.LittleEndian.putShort(LittleEndian.java:243)
        at
org.apache.poi.hssf.record.SelectionRecord.serialize(SelectionRecord.java:262)
        at org.apache.poi.hssf.model.Sheet.serialize(Sheet.java:584)
        at
org.apache.poi.hssf.usermodel.HSSFWorkbook.getBytes(HSSFWorkbook.java:522)
        at org.apache.poi.hssf.usermodel.HSSFWorkbook.write(HSSFWorkbook.java:474)
        at
org.apache.poi.hssf.usermodel.TestFormulas.testAddIntegers(TestFormulas.java:130)
        at org.apache.poi.hssf.usermodel.TestFormulas.main(TestFormulas.java:157)


oddly if I increase from 4 to 10 I get this instead:

There was 1 error:
1) testAddIntegers(org.apache.poi.hssf.usermodel.TestFormulas)
java.lang.ArrayIndexOutOfBoundsException
        at org.apache.poi.util.LittleEndian.putNumber(LittleEndian.java:536)
        at org.apache.poi.util.LittleEndian.putShort(LittleEndian.java:243)
        at
org.apache.poi.hssf.record.FormulaRecord.serialize(FormulaRecord.java:353)
        at
org.apache.poi.hssf.record.aggregates.ValueRecordsAggregate.serialize(ValueRecordsAggregate.java:174)
        at org.apache.poi.hssf.model.Sheet.serialize(Sheet.java:584)
        at
org.apache.poi.hssf.usermodel.HSSFWorkbook.getBytes(HSSFWorkbook.java:522)
        at org.apache.poi.hssf.usermodel.HSSFWorkbook.write(HSSFWorkbook.java:474)
        at
org.apache.poi.hssf.usermodel.TestFormulas.testAddIntegers(TestFormulas.java:130)
        at org.apache.poi.hssf.usermodel.TestFormulas.main(TestFormulas.java:157)

This is weird!
Comment 1 Andy Oliver 2002-04-28 00:42:13 UTC

*** This bug has been marked as a duplicate of 8592 ***