Bug 8660 - Importing absolute URL resources doesn't behave as spec if code is other than 200.
Summary: Importing absolute URL resources doesn't behave as spec if code is other than...
Status: CLOSED WONTFIX
Alias: None
Product: Taglibs
Classification: Unclassified
Component: Standard Taglib (show other bugs)
Version: unspecified
Hardware: All All
: P3 critical (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-04-30 14:50 UTC by Ryan Lubke
Modified: 2004-11-16 19:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Lubke 2002-04-30 14:50:43 UTC
After the Fix for 8650, I've discovered that if a resource being imported via
an absolute URL sends a 302 (redirect) that the redirect is followed.

Additionally, in the case of, say, 410, a FileNotFoundException is returned by
the HttpURLConnection.  In the case of a 100, the status code return by
HttpUrlConnect ion is '-1'
Comment 1 Shawn Bayern 2002-05-01 03:41:07 UTC
Not a bug - spec clarified.