Bug 8903 - CONNECT Proxy not working
Summary: CONNECT Proxy not working
Status: CLOSED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_proxy (show other bugs)
Version: 2.0.36
Hardware: PC All
: P3 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
: 8735 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-05-08 09:39 UTC by Jorge Serna
Modified: 2005-03-20 17:06 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge Serna 2002-05-08 09:39:26 UTC
I have instaled the precompiled version of Apache Web Server 2.0.36. The only 
configuration modifications made are:

- Uncomment use of proxy modules

LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule proxy_http_module modules/mod_proxy_http.so

- Use of proxy directives

#
# Proxy Server directives. Uncomment the following lines to
# enable the proxy server:
#
<IfModule mod_proxy.c>
ProxyRequests On

AllowCONNECT  443 4081

<Proxy *>
    Order deny,allow
#    Deny from all
#    Allow from .tid
    Allow from all
</Proxy>

#
# Enable/disable the handling of HTTP/1.1 "Via:" headers.
# ("Full" adds the server version; "Block" removes all outgoing Via: headers)
# Set to one of: Off | On | Full | Block
#
ProxyVia On

#
# To enable the cache as well, edit and uncomment the following lines:
# (no cacheing without CacheRoot)
#
#CacheRoot "C:/Archivos de programa/Apache Group/Apache2/proxy"
#CacheSize 5
#CacheGcInterval 4
#CacheMaxExpire 24
#CacheLastModifiedFactor 0.1
#CacheDefaultExpire 1
#NoCache a-domain.com another-domain.edu joes.garage-sale.com

</IfModule>
# End of proxy directives.


HTTP proxy works fine, but I seem unable to access HTTPS pages via proxy. When 
accesing a valid https URL inside my domain (https://brisa.tid:4081/) the Web 
browser (Netscape 4.7 or IE 5.5) hangs for a while before informing that the 
document accesed is empty.

Access log shows:

1.0.25.254 - - [08/May/2002:10:29:49 +0100] "CONNECT brisa.tid:4081 HTTP/1.0" 
200 -
1.0.25.254 - - [08/May/2002:10:40:53 +0100] "CONNECT brisa.tid:4081 HTTP/1.0" 
200 -
1.0.25.254 - - [08/May/2002:11:22:12 +0100] "CONNECT brisa.tid:443 HTTP/1.0" 
200 -
Comment 1 Jeff Trawick 2002-05-08 11:10:37 UTC
This was fixed over the last few days and will be in 2.0.37.

If you want to  apply the patch yourself and rebuild Apache, here
is the critical change:

http://cvs.apache.org/viewcvs.cgi/httpd-2.0/modules/proxy/
proxy_connect.c.diff?r1=1.56&r2=1.57
Comment 2 Jeff Trawick 2002-05-13 13:51:08 UTC
*** Bug 8735 has been marked as a duplicate of this bug. ***