Bug 9550 - ant script needs " around directory names
Summary: ant script needs " around directory names
Status: RESOLVED FIXED
Alias: None
Product: Ant
Classification: Unclassified
Component: Wrapper scripts (show other bugs)
Version: 1.5
Hardware: PC All
: P3 minor (vote)
Target Milestone: 1.5.2
Assignee: Ant Notifications List
URL:
Keywords:
: 10695 17452 (view as bug list)
Depends on:
Blocks:
 
Reported: 2002-05-31 19:28 UTC by bafish
Modified: 2008-02-22 12:18 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bafish 2002-05-31 19:28:21 UTC
I'm running Win2K using cygwin and our repostory has directories with spaces in
them.  The script at ./jakarta-ant-1.5beta1/bin/ant needs quotes around the
argument passed to cd.  From:

   cd $savedir

to:

   cd "$savedir"

Otherwise ant can't seem to find the build.xml file in the current directory.  I
also downloaded and tried the 1.6Alpha nightly build for 5/30/2002 and it has
the same problem.

/will
Comment 1 Stefan Bodewig 2002-07-12 14:53:16 UTC
*** Bug 10695 has been marked as a duplicate of this bug. ***
Comment 2 Stefan Bodewig 2002-07-12 15:16:29 UTC
Thanks
Comment 3 Stefan Bodewig 2002-07-16 07:13:36 UTC
A fixed version of the script is available as a side-effect of
<http://jakarta.apache.org/ant/faq.html#1.5-cygwin-sh>.
Comment 4 Conor MacNeill 2003-02-26 22:14:29 UTC
*** Bug 17452 has been marked as a duplicate of this bug. ***