This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

View | Details | Raw Unified | Return to bug 221381
Collapse All | Expand All

(-)a/api.annotations.common/apichanges.xml (+16 lines)
Lines 108-113 Link Here
108
    <!-- ACTUAL CHANGES BEGIN HERE: -->
108
    <!-- ACTUAL CHANGES BEGIN HERE: -->
109
109
110
    <changes>
110
    <changes>
111
        <change id="SuppressWarningsJustification">
112
            <api name="common_annotations_api"/>
113
            <summary>Added justification attribute to <code>SuppressWarnings</code></summary>
114
            <version major="1" minor="18"/>
115
            <date day="1" month="1" year="2013"/>
116
            <author login="phejl"/>
117
            <compatibility addition="yes"/>
118
            <description>
119
                <p>
120
                    Introduced justificatio attribute to specify why it is ok to
121
                    suppress a warning.
122
                </p>
123
            </description>
124
            <class package="org.netbeans.api.annotations.common" name="SuppressWarnings"/>
125
            <issue number="221381"/>
126
        </change>
111
        <change id="StaticResource">
127
        <change id="StaticResource">
112
            <api name="common_annotations_api"/>
128
            <api name="common_annotations_api"/>
113
            <summary>Added <code>StaticResource</code></summary>
129
            <summary>Added <code>StaticResource</code></summary>
(-)a/api.annotations.common/manifest.mf (-1 / +1 lines)
Lines 2-6 Link Here
2
AutoUpdate-Show-In-Client: false
2
AutoUpdate-Show-In-Client: false
3
OpenIDE-Module: org.netbeans.api.annotations.common/1
3
OpenIDE-Module: org.netbeans.api.annotations.common/1
4
OpenIDE-Module-Localizing-Bundle: org/netbeans/annotations/common/resources/Bundle.properties
4
OpenIDE-Module-Localizing-Bundle: org/netbeans/annotations/common/resources/Bundle.properties
5
OpenIDE-Module-Specification-Version: 1.17
5
OpenIDE-Module-Specification-Version: 1.18
6
6
(-)a/api.annotations.common/src/org/netbeans/api/annotations/common/SuppressWarnings.java (+9 lines)
Lines 62-65 Link Here
62
     */
62
     */
63
    String[] value() default {};
63
    String[] value() default {};
64
64
65
    /**
66
     * The justification for the suppression. Should be human readable
67
     * description explaining why it is ok to suppress the message(s).
68
     *
69
     * @return the justification for the suppression
70
     * @since 1.18
71
     */
72
    String justification() default "";
73
65
}
74
}

Return to bug 221381