This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 100853

Summary: Unable to connect to Derby using the Java DB Embedded driver
Product: db Reporter: rpoon <rpoon>
Component: DerbyAssignee: David Vancouvering <davidvc>
Status: RESOLVED INVALID    
Severity: blocker CC: hong_lin
Priority: P2 Keywords: RELNOTE
Version: 6.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:
Attachments: App Server Admin Console Connection Error
IDE Connection failed
Java DB (Derby) Embedded Driver
Related email

Description rpoon 2007-04-12 21:52:28 UTC
Build: Enterprise Pack - Build 8a

http://ivory.russia/entpack-6.0-m8a/take3/
nb-ide_nb-soa_glassfish_openesb_sjsam_windows.exe

===============================================
Note:
This problem was included as one of the problem items in ticket 100039 for 
Derby database connection.

I enter this ticket for the 'connection problem with the Embedded driver' to 
keep track of this problem seperately.

------------------------------------------

User is unable to use the installation provided 'Java DB (Embedded)' driver to 
connect to local Derby database while I am able to connect to the same local 
Derby database with Java DB (Network) driver.

The problem is encountered in both NetBean IDE (under runtime) as well as in 
App Server Admin Console.

(see attached Jpeg files for details)
Comment 1 rpoon 2007-04-12 21:53:12 UTC
Created attachment 40854 [details]
App Server Admin Console Connection Error
Comment 2 rpoon 2007-04-12 22:03:02 UTC
Created attachment 40855 [details]
IDE Connection failed
Comment 3 rpoon 2007-04-12 22:03:37 UTC
Created attachment 40856 [details]
Java DB (Derby) Embedded Driver
Comment 4 rpoon 2007-04-12 22:04:14 UTC
Created attachment 40857 [details]
Related email
Comment 5 Venkat Srinivasan 2007-04-16 06:24:04 UTC
Please look into this.
Comment 6 Narayana Pedapudi 2007-04-16 12:36:52 UTC
This is netbeans bug please assign to the respective team.
Comment 7 _ hong_lin 2007-08-09 13:55:06 UTC
Hi rpoon,

Issue 100039 is fixed already. Would you please help to verify if this issue is still reproducible in the latest NB 6.0
nightly build?
Comment 8 Sergey Lunegov 2008-01-18 10:59:25 UTC
reassigning to more appropriate category
Comment 9 Jayashri Visvanathan 2008-01-19 01:39:54 UTC
Hong,
   Can you please help reproduce the problem and assign it to the right category ? I don't see why this is being
assigned to j2ee/persistance ?
thanks
Comment 10 Andrei Badea 2008-01-21 14:28:58 UTC
The problem seems to be that the Derby system home is not ~/.netbeans-derby when connecting when the embedded driver.
Comment 11 David Vancouvering 2008-01-22 19:25:09 UTC
rpoon: Can you get the following information for me please?

- Please attach the message log for the IDE.  It's under your userdir at /var/log/messages.log.  Please see this FAQ for
finding your userdir

- Please give me the value for the Java DB location, at Tools->Java DB Database->Settings->Database Location (for
NetBeans 6)

- Are you using NetBeans 6.0 or 5.5?  I can't tell for sure -- the bug says it's NetBeans 6.1 but I wanted to verify that.

- Can you search your filesystem for the directory named 'sample' and see if you can find the location, and tell me
where it is?  In particular, look for a directory named 'sample' in the directory .netbeans-derby under your home directory.

- What platform are you on?  Linux, Windows, Mac, Solaris?

Just for your information, the URL "jdbc:derby:sample" indicates a *relative* path to the database.  This path is
determined by the following algorithm:

* If the Java system property derby.system.home is set, look for the database there
* If derby.system.home is not set, is uses the Java system property "user.dir", which in this case is the location where
NetBeans was started

So what is happening is that either (a) the Java DB driver is looking in the wrong place for the database or (b) the
database is not where it is supposed to be.  I'm trying to figure out which of these it is.  In general connecting to
the sample database works just fine for the standard installation of NetBeans...
Comment 12 David Vancouvering 2008-06-17 19:04:53 UTC
Closing, user not responding to request for information.  rpoon, if you get me the information I need, please add it to
this issue and re-open, thanks.