This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 112085

Summary: [a11y] Missing mnemonic Window > Other > Ruby Shell
Product: ruby Reporter: Petr Chytil <pchytil>
Component: CodeAssignee: Torbjorn Norbye <tor>
Status: RESOLVED FIXED    
Severity: blocker CC: jrojcek
Priority: P4 Keywords: A11Y, SIMPLEFIX
Version: 6.x   
Hardware: All   
OS: All   
Issue Type: DEFECT Exception Reporter:

Description Petr Chytil 2007-08-06 16:35:05 UTC
Product Version: NetBeans IDE Dev (Build 200708060000) 
Java: 1.5.0_12; Java HotSpot(TM) Client VM 1.5.0_12-b04 
System: Linux version 2.6.20-16-generic running on i386 (616:7); UTF-8; en_US (nb) 
Userdir: /home/petr/.netbeans/dev

Missing mnemonic Window > Other > Ruby Shell

mnemonics should be set according to this permanent UI spec:
http://wiki.netbeans.org/wiki/view/MainMenu
Comment 1 Martin Krauskopf 2007-09-06 21:42:37 UTC
projects/src/org/netbeans/modules/ruby/rubyproject/Bundle.properties;
new revision: 1.12; previous revision: 1.11
Comment 2 Martin Krauskopf 2007-09-06 21:46:34 UTC
Petre, I've fixed mnemonic, but left the text as "Ruby Shell (IRB)" instead of just "Ruby Shell" as it is in the
specification. I think that rather specification should be adjusted and add " (IRB)", since it really well known in the
community. I believe that more than "Ruby Shell". If you or anybody is strongly against, let us know. Thanks.
Comment 3 Martin Krauskopf 2007-09-17 14:57:20 UTC
Jano please see my last note and either let me know if you disagree with keeping " (IRB)" in the menu or we should
change the specification - add " (IRB)" there. As I said I think that almost all Rubyists know rather the term "irb" (in
the beginning of almost all introductory text/books) then Ruby Shell. So I'm for keeping IRB there.
(I've heard it is important to let you know about such changes....)
Comment 4 jrojcek 2007-10-09 15:31:28 UTC
I'm back from vacation. I'll review the menu changes and let you know if I have any objections. ;-) Thanks.
Comment 5 Martin Krauskopf 2008-02-13 15:39:25 UTC
Getting rid of 'ui' category. Will use right subcomponent and UI keyword. 'code'
when none subcomponent fits.