This Bugzilla instance is a read-only archive of historic NetBeans bug reports. To report a bug in NetBeans please follow the project's instructions for reporting issues.

Bug 115670

Summary: Ability to define cache location instead of dev/var/cache and ability to clean it
Product: platform Reporter: kawkhins <kawkhins>
Component: -- Other --Assignee: issues@platform <issues>
Status: RESOLVED DUPLICATE    
Severity: blocker    
Priority: P3    
Version: 6.x   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Exception Reporter:

Description kawkhins 2007-09-17 10:14:37 UTC
The cache of info about classes is located in netbeans preference folder, in
./dev/var/cache

It contains many old data (For one classe, several .sig files). Also, it contains data for unused projects.

We should be able to clean this easily, or to define an alternate location (temporary folder).
Or, other solution, when we clean a project/subprojects, all related data should be cleaned from this cache (which is
not the case). This solution is simpler and transparent for the user.
Comment 1 Petr Dvorak 2008-04-23 14:37:39 UTC
*** Issue 121566 has been marked as a duplicate of this issue. ***
Comment 2 Jana Maleckova 2008-09-18 08:44:24 UTC
you can change the location of the whole userdir using switch --userdir when you start nb ..
see FAQ http://wiki.netbeans.org/FaqAlternateUserdir

cleaning cache via GUI => reassign to project for evaluation
Comment 3 Milan Kubec 2008-10-15 10:22:15 UTC
Probably core wide issue.
Comment 4 b166er 2008-11-12 09:39:37 UTC
oh yes, define alternate location for cache is the best solution for me too.
we have MS Small-Business-Server with user-profiles that will be saved on server.
my NB-user-dir is now more than 300MB, my limit on server-profile is 500mb.
to clean cache befor every logout is very stressful. 
best solution is to have the option to set other location for cache (maybe: %TEMP%), 
because my NB-settings must be saved on my server profile, but cache must only stay on local-pc.
my opinion.
thanks
Comment 5 pekarna 2011-05-06 17:06:51 UTC
Could this be reconsidered for NetBeans 7.0 please?
Comment 6 pekarna 2011-05-06 17:08:57 UTC
+1 to  per-project cleanup - that's the best option from my POV.
Comment 7 mihai 2012-01-17 07:31:53 UTC
It will be nice to add a variable to specify the cache location. I have a computer with 8 GB RAM and I want to mount a folder to RAM (tmpfs) and then use that folder for NetBeans cache.

If I use --userdir then I will loose all the settings on a restart.
Comment 8 Jiri Rechtacek 2012-02-09 10:34:03 UTC
Already fixed in NetBeans 7.1. Just use --cachedir to separate your cache on desired location.

*** This bug has been marked as a duplicate of bug 57798 ***